pumpkin: ffmpeg: enable VMAF
[julm/julm-nix.git] / hosts / aubergine / sftp.nix
index 4f585b5b63962d1bc43dd26f1c5cd55f720e6e21..666aabf95ce3836f5cd56fe75f00a066548fe14c 100644 (file)
@@ -8,7 +8,7 @@ in
       where = "${sftpRoot}/films";
       type = "none";
       what = "/mnt/off3/julm/public/podcasts/films";
-      options = "bind,ro,noauto";
+      options = "bind,rw,noauto";
       requires = [ "zfs-import@off3.service" ];
       after = [
         "zfs-import@off3.service"
@@ -30,10 +30,10 @@ in
       #automountConfig.TimeoutIdleSec = "5 min";
     }
   ];
-  fileSystems."${sftpRoot}/camera" = {
-    device = "/mnt/off2/julm/perso/camera";
-    options = [ "bind" "ro" "noauto" ];
-  };
+  #fileSystems."${sftpRoot}/camera" = {
+  #  device = "/mnt/off2/julm/perso/camera";
+  #  options = [ "bind" "ro" "noauto" ];
+  #};
   services.openssh.extraConfig = ''
     Match User sevy
       AllowAgentForwarding no
@@ -42,11 +42,4 @@ in
       ForceCommand internal-sftp -u 0002
       X11Forwarding no
   '';
-
-  services.udev.extraRules = ''
-    SUBSYSTEM=="block", KERNEL=="sd*", ENV{ID_SERIAL}=="TOSHIBA_MK6459GSXP_519DC07HT", \
-      ACTION=="add", ENV{SYSTEMD_WANTS}+="zfs-import@off3.service"
-    SUBSYSTEM=="block", KERNEL=="sd*", ENV{ID_SERIAL}=="TOSHIBA_MK6459GSXP_519DC07HT", \
-      ACTION=="remove", RUN+="${pkgs.systemd}/bin/systemctl stop --no-block zfs-import@off3.service"
-  '';
 }