-{ pkgs, lib, config, ... }:
+{
+ pkgs,
+ lib,
+ config,
+ ...
+}:
{
imports = [
../../nixos/profiles/printing.nix
../../nixos/profiles/hardware/HP_Deskjet_1510.nix
];
services.printing = {
- listenAddresses = ["*:631"];
+ listenAddresses = [ "*:631" ];
defaultShared = true;
webInterface = true;
- allowFrom = ["all"];
+ allowFrom = [ "all" ];
openFirewall = true;
browsing = true;
extraConf = ''
+ DefaultEncryption IfRequested
ServerAlias *
'';
};
tcp dport ipp counter accept comment "cupsd: IPP"
}
}
- '' + lib.optionalString config.services.saned.enable ''
+ ''
+ + lib.optionalString config.services.saned.enable ''
table inet filter {
ct helper conntrack-sane {
type "sane" protocol tcp;