wine: add profile
[julm/julm-nix.git] / hosts / aubergine / printing.nix
index 2dcb375f766d98d871a7ae8bda04bc1b85468717..ee3463882a34210082fa09dae7c6db7c5d7da318 100644 (file)
@@ -1,17 +1,23 @@
-{ pkgs, lib, config, ... }:
+{
+  pkgs,
+  lib,
+  config,
+  ...
+}:
 {
   imports = [
     ../../nixos/profiles/printing.nix
     ../../nixos/profiles/hardware/HP_Deskjet_1510.nix
   ];
   services.printing = {
-    listenAddresses = ["*:631"];
+    listenAddresses = [ "*:631" ];
     defaultShared = true;
     webInterface = true;
-    allowFrom = ["all"];
+    allowFrom = [ "all" ];
     openFirewall = true;
     browsing = true;
     extraConf = ''
+      DefaultEncryption IfRequested
       ServerAlias *
     '';
   };
@@ -34,7 +40,8 @@
           tcp dport ipp counter accept comment "cupsd: IPP"
         }
       }
-    '' + lib.optionalString config.services.saned.enable ''
+    ''
+    + lib.optionalString config.services.saned.enable ''
       table inet filter {
         ct helper conntrack-sane {
           type "sane" protocol tcp;