home-manager: update
[julm/julm-nix.git] / flake.nix
index c9ff382df685df94c0a7a288dcd6823bf3dde79a..8a1dc6b7414c07f0514d9b72121186204a987a74 100644 (file)
--- a/flake.nix
+++ b/flake.nix
 {
-inputs.nixpkgs.url = "github:NixOS/nixpkgs/495b19d5b3e62b4ec7e846bdfb6ef3d9c3b83492";
-inputs.home-manager.url = "github:nix-community/home-manager";
-inputs.home-manager.inputs.nixpkgs.follows = "nixpkgs";
-inputs.doom-emacs.url = "github:hlissner/doom-emacs";
-inputs.doom-emacs.flake = false;
-/*
-inputs.nix-doom-emacs.url = "github:vlaci/nix-doom-emacs";
-inputs.nix-doom-emacs.inputs.nixpkgs.follows = "nixpkgs";
-inputs.nix-doom-emacs.inputs.home-manager.follows = "home-manager";
-inputs.nix-doom-emacs.inputs.flake-utils.follows = "flake-utils";
-inputs.nix-doom-emacs.inputs.emacs-overlay.follows = "emacs-overlay";
-inputs.emacs-overlay.url = "github:nix-community/emacs-overlay/master";
-*/
-#inputs.pass = { type = "path"; path = "./pass"; flake = false; };
+  description = "julm's Nix configurations for hosts (NixOS) and homes (home-manager)";
+  /*
+    nixConfig = {
+    extra-substituters = [
+      "https://nix-community.cachix.org"
+    ];
+    extra-trusted-public-keys = [
+      "nix-community.cachix.org-1:mB9FSh9qf2dCimDSUo8Zy7bkq5CX+/rkCWyvRCYg3Fs="
+    ];
+    };
+  */
 
-outputs = inputs: let
-  remoteNixpkgsPatches = import nixpkgs/patches.nix;
-  localNixpkgsPatches = [
-  ];
-  originPkgs = inputs.nixpkgs.legacyPackages."x86_64-linux";
-  nixpkgsPath = originPkgs.applyPatches {
-    name = "nixpkgs-patched";
-    src = inputs.nixpkgs.outPath;
-    patches = map originPkgs.fetchpatch remoteNixpkgsPatches ++ localNixpkgsPatches;
-    postPatch = ''
-      patch=$(printf '%s\n' ${builtins.concatStringsSep " "
-         (map (p: p.sha256) remoteNixpkgsPatches ++ localNixpkgsPatches)} |
-        sort | sha256sum | cut -c -7)
-      echo "-patch-$patch" >.version-suffix
-    '';
+  inputs = {
+    doom-emacs.flake = false;
+    doom-emacs.url = "github:hlissner/doom-emacs";
+    git-hooks.inputs.nixpkgs.follows = "nixpkgs";
+    git-hooks.url = "github:cachix/git-hooks.nix";
+    home-manager.inputs.nixpkgs.follows = "nixpkgs";
+    home-manager.url = "github:nix-community/home-manager/release-24.11";
+    nixos-hardware.url = "github:NixOS/nixos-hardware/master";
+    nixpkgs.url = "github:NixOS/nixpkgs/nixos-24.11";
   };
-  lib = inputs.nixpkgs.lib;
-  forAllSystems = f: lib.genAttrs lib.systems.flakeExposed (system: f rec {
-    inherit system;
-    #pkgs = inputs.nixpkgs.legacyPackages.${system};
-    pkgs = import nixpkgsPath {
-      inherit system;
-      config = {
-        allowUnfree = true; # For hplip
+
+  outputs =
+    inputs:
+    let
+      remoteNixpkgsPatches = import nixpkgs/patches.nix;
+      localNixpkgsPatches = [
+      ];
+      originPkgs = inputs.nixpkgs.legacyPackages."x86_64-linux";
+      nixpkgsPath = originPkgs.applyPatches {
+        name = "nixpkgs-patched";
+        src = inputs.nixpkgs.outPath;
+        patches = map originPkgs.fetchpatch remoteNixpkgsPatches ++ localNixpkgsPatches;
+        postPatch = ''
+          patch=$(printf '%s\n' ${
+            builtins.concatStringsSep " " (map (p: p.sha256) remoteNixpkgsPatches ++ localNixpkgsPatches)
+          } |
+            sort | sha256sum | cut -c -7)
+          echo "-patch-$patch" >.version-suffix
+        '';
       };
-      overlays = import nixpkgs/overlays.nix;
-    };
-  });
-  nixosSystem = import (nixpkgsPath + "/nixos/lib/eval-config.nix");
-  #nixosSystem = inputs.nixpkgs.lib.nixosSystem;
-  in {
-    nixosConfigurations = lib.genAttrs
-      (builtins.attrNames (lib.filterAttrs (n: v: v == "directory") (builtins.readDir ./hosts)))
-      (hostName: nixosSystem {
-        system = "x86_64-linux";
-        pkgs = import nixpkgsPath {
-          system = "x86_64-linux";
-          config = {
-            allowUnfree = true; # For hplip
-          };
-          overlays = import nixpkgs/overlays.nix;
-        };
-        specialArgs = {
-          inherit hostName inputs;
-        };
-        modules = [
-          {
-            config._module.args = {
-              inherit hostName inputs;
-              hosts = inputs.self.nixosConfigurations;
+      profile = "/nix/var/nix/profiles/system";
+      inherit (inputs.nixpkgs) lib;
+      overlays =
+        system:
+        import nixpkgs/overlays.nix
+        ++ [
+        ];
+      #nixosSystem = lib.nixosSystem;
+      nixosSystem = import (nixpkgsPath + "/nixos/lib/eval-config.nix");
+      forAllSystems =
+        f:
+        lib.genAttrs lib.systems.flakeExposed (
+          system:
+          f rec {
+            inherit system;
+            #pkgs = inputs.nixpkgs.legacyPackages.${system};
+            pkgs = import nixpkgsPath {
+              inherit system;
+              overlays = overlays system;
             };
           }
-          (import nixos/modules.nix)
-          (import nixos/options.nix)
-          (import (./hosts + "/${hostName}.nix"))
-          inputs.nixpkgs.nixosModules.notDetected
-          inputs.home-manager.nixosModules.home-manager
-          ({ pkgs, ... }: {
-            nix.registry.nixpkgs = lib.mkDefault { flake = inputs.nixpkgs; };
-            nix.package = pkgs.nixFlakes;
-            nix.extraOptions = "experimental-features = nix-command flakes";
-            #nixpkgs.overlays = import nixpkgs/overlays.nix;
-            /*
-            system.nixos.versionSuffix = ".${
-              lib.substring 0 8 (inputs.self.lastModifiedDate or inputs.self.lastModified)}.${
-              inputs.self.shortRev or "dirty"}";
-            system.nixos.revision = lib.mkIf (inputs.self ? rev) inputs.self.rev;
-            */
-            # Let 'nixos-version --json' know about the Git revision of this flake.
-            system.configurationRevision = lib.mkIf (inputs.self ? rev) inputs.self.rev;
-            /*
-            system.configurationRevision =
-              if inputs.self ? rev
-              then inputs.self.rev
-              else throw "Refusing to build from a dirty Git tree!";
-            */
-          })
-          {
-            home-manager.useGlobalPkgs = true;
-            home-manager.useUserPackages = true;
-            home-manager.verbose = true;
-            home-manager.backupFileExtension = null;
-            home-manager.extraSpecialArgs = {
-              inherit hostName inputs;
+        );
+      self =
+        with lib.fileset;
+        toSource {
+          root = ./.;
+          fileset =
+            let
+              exts = [
+                "clear"
+                "conf"
+                "cred"
+                "crt"
+                "css"
+                "el"
+                "hs"
+                "json"
+                "lua"
+                "nix"
+                "patch"
+                "pem"
+                "pub"
+                "sh"
+                "theme"
+                "vim"
+              ];
+            in
+            unions [
+              (fileFilter (file: lib.any file.hasExt exts) ./domains)
+              (fileFilter (file: lib.any file.hasExt exts) ./home-manager)
+              (fileFilter (file: lib.any file.hasExt exts) ./homes)
+              (fileFilter (file: lib.any file.hasExt exts) ./hosts)
+              (fileFilter (file: lib.any file.hasExt exts) ./nixos)
+              (fileFilter (file: lib.any file.hasExt exts) ./nixpkgs)
+              (fileFilter (file: lib.any file.hasExt exts) ./users)
+              ./shell.nix
+            ];
+        };
+    in
+    rec {
+      # nix -L build .#hello
+      packages = forAllSystems ({ pkgs, ... }: pkgs);
+
+      # nix -L build .#nixosConfigurations.oignon.config.system.build.toplevel
+      # nix -L build .#nixosConfigurations.oignon.config.boot.kernelPackages.kernel.configfile
+      # nix -L build .#nixosConfigurations.oignon.pkgs.hello
+      # nix eval --raw .#nixosConfigurations.oignon.config.networking.nftables.ruleset
+      nixosConfigurations =
+        lib.genAttrs
+          (builtins.attrNames (
+            lib.filterAttrs (_n: v: v == "directory") (builtins.readDir (self + "/hosts"))
+          ))
+          (
+            hostName:
+            nixosSystem {
+              system = null;
+              specialArgs = {
+                # Required to avoid infinite recursion
+                # when `inputs` is used in `imports`.
+                inherit inputs;
+              };
+              modules = [
+                nixos/default.nix
+                (import (self + "/hosts/${hostName}.nix"))
+                (
+                  { config, ... }:
+                  {
+                    _module.args = {
+                      inherit hostName;
+                      hosts = nixosConfigurations;
+                      host = nixosConfigurations.${hostName}._module.args;
+                    };
+                    nixpkgs.overlays = overlays config.nixpkgs.hostPlatform.system;
+                    nixpkgs.config.permittedInsecurePackages = [
+                      # Still needed for chatty
+                      # See https://github.com/NixOS/nixpkgs/pull/334638#issuecomment-2289025802%3E
+                      # and https://gitlab.gnome.org/World/Chatty/-/issues/932
+                      "olm-3.2.16"
+                    ];
+                    nixpkgs.config.allowUnfreePredicate =
+                      pkg:
+                      builtins.elem (lib.getName pkg) [
+                        "anydesk"
+                        "canon-cups-ufr2"
+                        "cudatoolkit"
+                        "geogebra"
+                        "hplip"
+                        "memtest86-efi"
+                        "nvidia-settings"
+                        "nvidia-x11"
+                      ];
+                  }
+                )
+                inputs.home-manager.nixosModules.home-manager
+                {
+                  home-manager.useGlobalPkgs = true;
+                  home-manager.useUserPackages = true;
+                  home-manager.verbose = true;
+                  #home-manager.force = true;
+                  home-manager.backupFileExtension = "old";
+                  home-manager.extraSpecialArgs = {
+                    inherit hostName inputs;
+                  };
+                }
+              ];
+            }
+          );
+
+      # nix -L develop  or  direnv allow
+      devShells = forAllSystems (
+        { pkgs, system, ... }:
+        {
+          default = pkgs.callPackage (self + "/shell.nix") {
+            inherit
+              pkgs
+              inputs
+              system
+              nixpkgsPath
+              ;
+            inherit (checks.${system}.git-hooks-check) shellHook;
+          };
+        }
+      );
+
+      # nix -L run .#oignon.switch
+      apps = forAllSystems (
+        { pkgs, system, ... }:
+        with builtins;
+        mapAttrs (
+          hostName:
+          { config, ... }:
+          let
+            inherit (config.system) build;
+            scriptApp = scriptName: ps: script: {
+              type = "app";
+              program =
+                (pkgs.writeShellScript "${hostName}-${scriptName}" ''
+                  export PATH="${lib.makeBinPath ([ pkgs.coreutils ] ++ ps)}:$PATH"
+                  set -eux
+                  ${script}
+                '').outPath;
             };
+          in
+          {
+            # Example: nix run .#aubergine.switch
+            "switch" = scriptApp "switch" [ ] ''
+              shopt -s globstar
+
+              chmod -R g-rwx,o-rwx **/*.gpg
+              trap 'git reset **/*.gpg' EXIT
+              git rm -rf --cached --ignore-unmatch **/*.gpg # prevent copying to /nix/store
+
+              nix-store --add-root hosts/${hostName}.nixpkgs --indirect --realise ${nixpkgsPath}
+              nix-store --add-root hosts/${hostName}.root --indirect --realise ${build.toplevel}
+
+              nix copy --to "ssh://${config.install.target}?''${targetStore-}"${lib.optionalString config.install.substituteOnDestination " --substitute-on-destination"} ${build.toplevel}
+
+              if ssh ${config.install.target} set -x ';' \
+                systemctl reset-failed nixos-fallback '2>/dev/null' ';' \
+                test "''${NO_NIXOS_FALLBACK:+set}" '||' \
+                systemd-run -u nixos-fallback --description=nixos-fallback /bin/sh -xc '''\'''
+                  PATH=${
+                    with pkgs;
+                    lib.makeBinPath [
+                      coreutils
+                      nix
+                      systemd
+                    ]
+                  }
+                  sleep $((10 * 60))
+                  ${profile}/bin/switch-to-configuration switch
+                  systemctl reboot
+                '\'''' '&&' \
+                ${build.toplevel}/bin/switch-to-configuration test
+              then
+                ssh ${config.install.target} -o ControlPath=none set -x ';' \
+                  systemctl stop nixos-fallback.service ';' \
+                  nix-env --profile ${profile} --set '${build.toplevel}' ';' \
+                  ${build.toplevel}/bin/switch-to-configuration boot '&&' \
+                  nix-env --delete-generations 7d --profile ${profile}
+              else
+                tput rev
+                echo WARNING: switch-to-configuration was not registered at boot
+                tput sgr0
+                ssh ${config.install.target} -o ControlPath=none set -x ';' \
+                  systemctl stop nixos-fallback.service
+                false
+              fi
+            '';
           }
-        ];
-      });
-    # nix -L develop  or  direnv allow
-    devShell = forAllSystems ({ pkgs, system, ... }: pkgs.callPackage ./shell.nix
-      {
-        inherit pkgs inputs system nixpkgsPath;
-        #inherit (checks.${system}.pre-commit-check) shellHook;
-      });
-    # nix -L run .#oignon.switch
-    apps = forAllSystems ({ pkgs, system, ... }:
-      with builtins;
-      mapAttrs (hostName: { config, ... }:
-        let
-          build = config.system.build;
-          target = "\"\${TARGET:-root@${config.networking.hostName}.${config.networking.domain}}\"";
-          profile = "/nix/var/nix/profiles/system";
-          nixos-fallback = { delay ? 5 * 60 }: pkgs.writeShellScript "nixos-fallback" ''
-            PATH=${with pkgs; lib.makeBinPath [ coreutils config.nix.package systemd ]}
-            set -eux
-            fallback=$(realpath -e -- ${profile})
-            sleep ${lib.escapeShellArg (toString delay)}
-            nix-env --profile ${profile} --set "$fallback"
-            $fallback/bin/switch-to-configuration switch
-            systemctl reboot
-          '';
-        in rec {
-        # Example: nix run .#aubergine.switch
-        "switch" = {
-          type = "app";
-          program = (pkgs.writeShellScript "switch" (''
-            set -eux
-            set -o pipefail
-            shopt -s globstar
-            chmod -R g-rwx,o-rwx **/*.gpg
-            trap 'git reset **/*.gpg' EXIT
-            git rm -rf --cached --ignore-unmatch **/*.gpg # prevent copying to /nix/store
+        ) nixosConfigurations
+      );
 
-            nix-store --add-root hosts/${hostName}.nixpkgs --indirect --realise ${nixpkgsPath}
-            nix-store --add-root hosts/${hostName}.root --indirect --realise ${build.toplevel}
-            nix copy --to ssh://${target}${lib.optionalString config.install.substituteOnDestination " --substitute-on-destination"} ${build.toplevel}
-            ssh ${target} \
-              systemctl reset-failed nixos-fallback '2>/dev/null' ';' \
-              systemd-run -u nixos-fallback ${nixos-fallback {}} ';' \
-              ${profile}/bin/switch-to-configuration test
-            ssh ${target} -o ControlPath=none \
-              systemctl stop nixos-fallback.service ';' \
-              nix-env --profile ${profile} --set '${build.toplevel}' ';' \
-              ${profile}/bin/switch-to-configuration boot '&&' \
-              nix-env --delete-generations 7d --profile ${profile}
-            ''
-          )).outPath;
-        };
-      }) inputs.self.nixosConfigurations);
-  };
+      # nix flake check
+      checks = forAllSystems (
+        args: with args; {
+          git-hooks-check = inputs.git-hooks.lib.${system}.run {
+            src = self;
+            hooks = {
+              nixfmt-rfc-style.enable = true;
+            };
+          };
+        }
+      );
+    };
 }