ssh: rename { networking/ssh => ssh }
[julm/julm-nix.git] / hosts / aubergine / hardware.nix
index fd0ca42380fc624a10c96e5617b1368e6180e16b..bb54cda4708f384a66095d2254afc4d56fb12abe 100644 (file)
@@ -1,87 +1,89 @@
-{ config, lib, pkgs, hostName, ... }:
+{ lib, hostName, ... }:
 {
-imports = [
-  ../../nixos/profiles/hardware/apu6b4.nix
-  ../../nixos/profiles/hardware/ME909u-521.nix
-  ../../nixos/profiles/zfs.nix
-  ../../nixos/profiles/zramSwap.nix
-];
-
-# Setting the machine-id avoids to reencrypt all credentials
-# when reinstalling NixOS on a new drive.
-# Manually generated with : uuidgen | tr -d -
-environment.etc.machine-id.text = "be4a9e8cde1145c1bfcff894e36206d6";
+  imports = [
+    ../../nixos/profiles/hardware/apu6b4.nix
+    ../../nixos/profiles/hardware/ME909u-521.nix
+    ../../nixos/profiles/zfs.nix
+    ../../nixos/profiles/zramSwap.nix
+  ];
 
-# The 32-bit host id of the host, formatted as 8 hexadecimal characters.
-# You should try to make this id unique among your hosts.
-# Manually generated with : uuidgen | head -c8
-networking.hostId = "408a404a";
+  # Setting the machine-id avoids to reencrypt all credentials
+  # when reinstalling NixOS on a new drive.
+  # Manually generated with : uuidgen | tr -d -
+  environment.etc.machine-id.text = "be4a9e8cde1145c1bfcff894e36206d6";
 
-/*
-boot.loader.efi = {
-  canTouchEfiVariables = true;
-  efiSysMountPoint = "/boot/efi";
-};
-*/
-boot.loader.grub = {
-  enable  = true;
-  version = 2;
-  devices = [
-    #"/dev/disk/by-id/mmc-SU08G_0xb0320f0f"
-    "/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
-  ];
-  configurationLimit = 9;
+  # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
+  # You should try to make this id unique among your hosts.
+  # Manually generated with : uuidgen | head -c8
+  networking.hostId = "408a404a";
 
-  #zfsSupport = true;
-  #efiSupport = true;
-  #enableCryptodisk = true;
-};
-boot.tmpOnTmpfs = true;
+  /*
+    boot.loader.efi = {
+    canTouchEfiVariables = true;
+    efiSysMountPoint = "/boot/efi";
+    };
+  */
+  boot.loader.grub = {
+    enable = true;
+    version = 2;
+    devices = [
+      #"/dev/disk/by-id/mmc-SU08G_0xb0320f0f"
+      "/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
+    ];
+    configurationLimit = 9;
 
-fileSystems."/" =
-  { device = "/dev/disk/by-partlabel/${hostName}_sd_root";
-    fsType = "ext4";
+    #zfsSupport = true;
+    #efiSupport = true;
+    #enableCryptodisk = true;
   };
-fileSystems."/boot/efi" =
-  { device = "/dev/disk/by-partlabel/${hostName}_sd_efi";
-    fsType = "vfat";
-  };
-/*
-swapDevices = [
-  { device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
+  boot.tmpOnTmpfs = true;
+
+  fileSystems."/" =
+    {
+      device = "/dev/disk/by-partlabel/${hostName}_sd_root";
+      fsType = "ext4";
+    };
+  fileSystems."/boot/efi" =
+    {
+      device = "/dev/disk/by-partlabel/${hostName}_sd_efi";
+      fsType = "vfat";
+    };
+  /*
+    swapDevices = [
+    { device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
     randomEncryption = {
       enable = true;
       cipher = "aes-xts-plain64";
       source = "/dev/urandom";
     };
-  }
-];
-*/
+    }
+    ];
+  */
 
-boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
-boot.extraModulePackages = [
-  #config.boot.kernelPackages.exfat-nofuse
-];
+  boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
+  boot.extraModulePackages = [
+    #config.boot.kernelPackages.exfat-nofuse
+  ];
 
-powerManagement.powertop.enable = true;
-#services.fprintd.enable = true;
+  powerManagement.powertop.enable = true;
+  #services.fprintd.enable = true;
 
-/*
-fileSystems."/" =
-  { device = "${hostName}/root";
+  /*
+    fileSystems."/" =
+    { device = "${hostName}/root";
     fsType = "zfs";
-  };
-fileSystems."/nix" =
-  { device = "${hostName}/nix";
+    };
+    fileSystems."/nix" =
+    { device = "${hostName}/nix";
     fsType = "zfs";
-  };
-fileSystems."/var" =
-  { device = "${hostName}/var";
+    };
+    fileSystems."/var" =
+    { device = "${hostName}/var";
     fsType = "zfs";
-  };
-*/
+    };
+  */
 
-hardware.pulseaudio.enable = lib.mkDefault true;
-#hardware.pulseaudio.tcp.enable = lib.mkDefault true;
+  hardware.pulseaudio.enable = lib.mkDefault true;
+  #hardware.pulseaudio.tcp.enable = lib.mkDefault true;
 
 }