nix: security: fix missing config
[julm/julm-nix.git] / nixos / profiles / hardware / ME909u-521.nix
index 1941a374e204804b2ddea0ea52f5478b140223d3..fad10ac28afd14823740ec9c81759fb21c8a64f2 100644 (file)
@@ -2,12 +2,17 @@
 # Beware that productId=1573 has been reused by Huawei for other cards...
 { pkgs, lib, ... }:
 {
-  # Enable usb_modeswitch
-  hardware.usbWwan.enable = true;
-
-  # Enable ModemManager
+  # sudo mmcli -m --command=
+  # - AT^WAKEUPCFG=?
+  # - Restart the module: AT+CFUN=1,1
+  # - Power off the module: AT^MSO
+  # - Set the +CREG unsolicited indication: AT+CREG=1
+  #
+  # sudo mmcli --modem 0 --set-allowed-modes='2G|3G|4G' --set-preferred-mode=4G
   networking.networkmanager.enable = true;
 
+  # Enable usb_modeswitch
+  hardware.usb-modeswitch.enable = true;
   # https://forum.openwrt.org/t/cdc-ether-ethertype-unknown-0x0808-on-huawei-me909u-521/5509/2
   # https://gitlab.freedesktop.org/mobile-broadband/ModemManager/-/issues/635
   environment.etc."usb_modeswitch.d".source = lib.mkForce (pkgs.writeTextDir "12d1:1573" ''
@@ -15,8 +20,6 @@
     Configuration=1
   '');
 
-  # sudo mmcli --modem 0 --set-allowed-modes='2G|3G|4G' --set-preferred-mode=4G
-
   environment.systemPackages = [
     pkgs.libqmi
   ];