pumpkin: lanzaboote: enable SecureBoot
[julm/julm-nix.git] / nixos / options.nix
index 78fda4cd29b47f92dd2adc85e766e99394576a5d..4e682b3ad40687e02b9f5d27ea80890b7666758f 100644 (file)
@@ -1,11 +1,21 @@
-{ lib, ... }:
+{ lib, config, ... }:
 with lib;
 {
   imports = [
     modules/security/systemd-creds.nix
   ];
   options = {
-    install.substituteOnDestination =
-      mkEnableOption "substitute-on-destination" // { default = true; };
+    install = {
+      target = mkOption {
+        type = types.str;
+        default = "\"\${NIXOS_TARGET:-root@${config.networking.hostName}.${config.networking.domain}}\"";
+        description = ''
+          SSH address to the target host's super-user.
+        '';
+      };
+      substituteOnDestination = mkEnableOption "substitute-on-destination" // {
+        default = true;
+      };
+    };
   };
 }