-{ lib, ... }:
+{ lib, config, ... }:
with lib;
{
imports = [
modules/security/systemd-creds.nix
];
options = {
- install.substituteOnDestination =
- mkEnableOption "substitute-on-destination" // { default = true; };
+ install = {
+ target = mkOption {
+ type = types.str;
+ default = "\"\${NIXOS_TARGET:-root@${config.networking.hostName}.${config.networking.domain}}\"";
+ description = ''
+ SSH address to the target host's super-user.
+ '';
+ };
+ substituteOnDestination = mkEnableOption "substitute-on-destination" // {
+ default = true;
+ };
+ };
};
}