nix: shell: install nixfmt-rfc-style
[julm/julm-nix.git] / hosts / oignon / hardware.nix
index faac47dde94b21f56dc4ff1a05428e0192e76269..1468f7ccaa20cf54c2747ff4e1427a2fd7f07c55 100644 (file)
@@ -9,7 +9,7 @@
   # Setting the machine-id avoids to reencrypt all credentials
   # when reinstalling NixOS on a new drive.
   # Manually generated with : uuidgen | tr -d -
-  environment.etc.machine-id.text = "46e396e54c264a3594d21de5c519dccf";
+  environment.etc.machine-id.source = ./machine-id.clear;
 
   # The 32-bit host id of the host, formatted as 8 hexadecimal characters.
   # You should try to make this id unique among your hosts.
@@ -24,7 +24,7 @@
   */
   boot.loader.grub = {
     enable = true;
-    version = 2;
+    memtest86.enable = true;
     devices = [
       "/dev/disk/by-id/ata-Samsung_SSD_850_PRO_128GB_S1SMNSAFC36436X"
     ];
     #efiSupport = true;
     #enableCryptodisk = true;
   };
+  boot.zfs.requestEncryptionCredentials = [ hostName ];
+
+  hardware.enableRedistributableFirmware = true;
 
   # Note that gobi_loader -2000 has to be rerun if the SIM is hot swapped
   services.udev.extraRules = ''
-    ACTION=="add", SUBSYSTEM=="tty", KERNEL=="ttyUSB*", ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9204", RUN+="${pkgs.gobi_loader}/lib/udev/gobi_loader -2000 $env{DEVNAME} /home/julm/documents/thinkpad-x201/gobi"
+    ACTION=="add", SUBSYSTEM=="tty", KERNEL=="ttyUSB*", ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9204", RUN+="${pkgs.gobi_loader}/lib/udev/gobi_loader -2000 $env{DEVNAME} /home/julm/files/thinkpad-x201/gobi"
   '';
 
   fileSystems."/boot" =
       fsType = "zfs";
     };
 
+  services.pipewire.jack.enable = true;
+
+  services.acpid = {
+    # Suspending not work well on this old computer.
+    lidEventCommands = "";
+  };
+
 }