pumpkin: shipwright: install
[julm/julm-nix.git] / nixos / profiles / tlp.nix
index e6f2aa5ffbd798aeb4ed61729358498c9524e3b8..02e7c603f41a884acffcbbc721c2416e466e9d35 100644 (file)
@@ -1,8 +1,15 @@
-{ lib, ... }:
+{ lib, config, ... }:
 with lib;
 {
+  # Preloading the kernel modules to avoid:
+  # tlp: Error in configuration at CPU_SCALING_GOVERNOR_ON_BAT="powersave": governor not available. Skipped.
+  boot.initrd.kernelModules = [
+    "cpufreq_ondemand"
+    "cpufreq_powersave"
+  ];
   services.tlp = {
-    enable = true;
+    # Gnome 40 introduced a new way of managing power, without tlp.
+    enable = mkDefault (!config.services.power-profiles-daemon.enable);
     settings = {
       CPU_SCALING_GOVERNOR_ON_AC = "ondemand";
       CPU_SCALING_GOVERNOR_ON_BAT = "powersave";