# Setting the machine-id avoids to reencrypt all credentials
# when reinstalling NixOS on a new drive.
# Manually generated with : uuidgen | tr -d -
- environment.etc.machine-id.text = "be4a9e8cde1145c1bfcff894e36206d6";
+ environment.etc.machine-id.source = ./machine-id.clear;
# The 32-bit host id of the host, formatted as 8 hexadecimal characters.
# You should try to make this id unique among your hosts.
*/
boot.loader.grub = {
enable = true;
- version = 2;
devices = [
#"/dev/disk/by-id/mmc-SU08G_0xb0320f0f"
- "/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
+ #"/dev/disk/by-id/usb-Generic-_Multi-Card_20071114173400000-0:0"
+ "/dev/disk/by-id/ata-YMTC_JGS_2201060101833"
];
configurationLimit = 9;
#efiSupport = true;
#enableCryptodisk = true;
};
- boot.tmpOnTmpfs = true;
-
- fileSystems."/" =
- {
- device = "/dev/disk/by-partlabel/${hostName}_sd_root";
- fsType = "ext4";
- };
- fileSystems."/boot/efi" =
- {
- device = "/dev/disk/by-partlabel/${hostName}_sd_efi";
- fsType = "vfat";
- };
- /*
- swapDevices = [
- { device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
- randomEncryption = {
- enable = true;
- cipher = "aes-xts-plain64";
- source = "/dev/urandom";
- };
- }
- ];
- */
+ boot.tmp.useTmpfs = true;
boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
boot.extraModulePackages = [
powerManagement.powertop.enable = true;
#services.fprintd.enable = true;
- /*
- fileSystems."/" =
- { device = "${hostName}/root";
- fsType = "zfs";
+ fileSystems."/" =
+ {
+ device = "${hostName}/root";
+ fsType = "zfs";
};
- fileSystems."/nix" =
- { device = "${hostName}/nix";
- fsType = "zfs";
+ fileSystems."/boot" =
+ {
+ device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
+ fsType = "ext4";
};
- fileSystems."/var" =
- { device = "${hostName}/var";
- fsType = "zfs";
+ fileSystems."/boot/efi" =
+ {
+ device = "/dev/disk/by-partlabel/${hostName}_ssd_efi";
+ fsType = "vfat";
};
- */
+ fileSystems."/nix" =
+ {
+ device = "${hostName}/nix";
+ fsType = "zfs";
+ };
+ fileSystems."/var" =
+ {
+ device = "${hostName}/var";
+ fsType = "zfs";
+ };
+ fileSystems."/home" =
+ {
+ device = "${hostName}/home";
+ fsType = "zfs";
+ };
+ swapDevices =
+ [
+ {
+ device = "/dev/disk/by-partlabel/${hostName}_ssd_swap";
+ randomEncryption = {
+ enable = true;
+ cipher = "aes-xts-plain64";
+ source = "/dev/urandom";
+ };
+ }
+ ];
hardware.pulseaudio.enable = lib.mkDefault true;
#hardware.pulseaudio.tcp.enable = lib.mkDefault true;