xmonad: rofi: import more environment variables
[julm/julm-nix.git] / nixos / profiles / hardware / ME909u-521.nix
index 1941a374e204804b2ddea0ea52f5478b140223d3..31fc779e94952f9f0c9053b79fe4f8abc36ec31c 100644 (file)
@@ -2,20 +2,25 @@
 # Beware that productId=1573 has been reused by Huawei for other cards...
 { pkgs, lib, ... }:
 {
-  # Enable usb_modeswitch
-  hardware.usbWwan.enable = true;
-
-  # Enable ModemManager
+  # sudo mmcli -m --command=
+  # - AT^WAKEUPCFG=?
+  # - Restart the module: AT+CFUN=1,1
+  # - Power off the module: AT^MSO
+  # - Set the +CREG unsolicited indication: AT+CREG=1
+  #
+  # sudo mmcli --modem 0 --set-allowed-modes='2G|3G|4G' --set-preferred-mode=4G
   networking.networkmanager.enable = true;
 
+  # Enable usb_modeswitch
+  hardware.usb-modeswitch.enable = true;
   # https://forum.openwrt.org/t/cdc-ether-ethertype-unknown-0x0808-on-huawei-me909u-521/5509/2
   # https://gitlab.freedesktop.org/mobile-broadband/ModemManager/-/issues/635
-  environment.etc."usb_modeswitch.d".source = lib.mkForce (pkgs.writeTextDir "12d1:1573" ''
-    # Huawei ME909u-521: select the QMI interface, which has qmi_wwan_rx_fixup()
-    Configuration=1
-  '');
-
-  # sudo mmcli --modem 0 --set-allowed-modes='2G|3G|4G' --set-preferred-mode=4G
+  environment.etc."usb_modeswitch.d".source = lib.mkForce (
+    pkgs.writeTextDir "12d1:1573" ''
+      # Huawei ME909u-521: select the QMI interface, which has qmi_wwan_rx_fixup()
+      Configuration=1
+    ''
+  );
 
   environment.systemPackages = [
     pkgs.libqmi