{ lib, ... }:
with (import ./names-and-numbers.nix);
+with (import ./names-and-numbers.nix.clear);
{
- services.dnscrypt-proxy2.settings.listen_addresses = [
- "${eth1IPv4}.1:53"
- "${eth2IPv4}.1:53"
- "${eth3IPv4}.1:53"
- ];
networking.interfaces = {
${eth1Iface} = {
useDHCP = false;
};
};
networking.networkmanager = {
- #enable = true;
unmanaged = [
eth1Iface
eth2Iface
oifname { ${eth1Iface}, ${eth2Iface}, ${eth3Iface} } jump output-lan
oifname { ${eth1Iface}, ${eth2Iface}, ${eth3Iface} } log level warn prefix "output-lan: " counter drop
}
+ chain forward-to-lan { }
+ chain forward {
+ iifname { "enp2s0", "enp3s0", "enp4s0", "wlp5s0" } oifname { "enp2s0", "enp3s0", "enp4s0", "wlp5s0" } goto forward-to-lan
+ }
}
'';
option domain-name-servers ${eth1IPv4}.1;
option routers ${eth1IPv4}.1;
option subnet-mask 255.255.255.0;
+ group {
+ host patate1 {
+ hardware ethernet ${patateMAC};
+ fixed-address ${eth1IPv4}.3;
+ }
+ }
}
subnet ${eth2IPv4}.0 netmask 255.255.255.0 {
option domain-name-servers ${eth2IPv4}.1;
option routers ${eth2IPv4}.1;
option subnet-mask 255.255.255.0;
+ group {
+ host patate2 {
+ hardware ethernet ${patateMAC};
+ fixed-address ${eth2IPv4}.3;
+ }
+ }
}
subnet ${eth3IPv4}.0 netmask 255.255.255.0 {
option domain-name-servers ${eth3IPv4}.1;
option routers ${eth3IPv4}.1;
option subnet-mask 255.255.255.0;
+ group {
+ host patate3 {
+ hardware ethernet ${patateMAC};
+ fixed-address ${eth3IPv4}.3;
+ }
+ }
}
'';
};
- services.openssh.listenAddresses = [
- { addr = "${eth1IPv4}.1"; port = 22; }
- { addr = "${eth2IPv4}.1"; port = 22; }
- { addr = "${eth3IPv4}.1"; port = 22; }
- ];
}