aubergine: nginx: fix /perso
[julm/julm-nix.git] / nixos / profiles / builder.nix
index 79622c0d88133aa0212bc014f93fd6f8cec0455b..4cd9fb26c366b9f1982929ced59cbd725d281d71 100644 (file)
@@ -1,21 +1,21 @@
-{ inputs, pkgs, lib, config, ... }:
+{ inputs, ... }:
 {
-nix.extraOptions = ''
-  experimental-features = nix-command flakes
-'';
-#nix.registry.self.flake = inputs.self;
-# Pin the rev to the revision of the public Nixpkgs that the system was built from.
-# This is the version which will be locked by flakes using flake:nixpkgs
-nix.registry.nixpkgs = {
-  from = { id = "nixpkgs"; type = "indirect"; };
-  to = {
-    owner = "NixOS";
-    repo = "nixpkgs";
-    rev = inputs.nixpkgs.rev;
-    type = "github";
+  nix.extraOptions = ''
+    experimental-features = nix-command flakes
+  '';
+  #nix.registry.self.flake = inputs.self;
+  # Pin the rev to the revision of the public Nixpkgs that the system was built from.
+  # This is the version which will be locked by flakes using flake:nixpkgs
+  nix.registry.nixpkgs = {
+    from = { id = "nixpkgs"; type = "indirect"; };
+    to = {
+      owner = "NixOS";
+      repo = "nixpkgs";
+      inherit (inputs.nixpkgs) rev;
+      type = "github";
+    };
   };
-};
-nix.nixPath = [
-  "nixpkgs=${inputs.nixpkgs}"
-];
+  nix.nixPath = [
+    "nixpkgs=${inputs.nixpkgs}"
+  ];
 }