networking/wifi.nix
networking/lte.nix
networking/nftables.nix
- wireguard/wg-intra.nix
+ ./wireguard.nix
../../nixos/profiles/dnscrypt-proxy2.nix
../../nixos/profiles/wireguard/wg-intra.nix
../../nixos/profiles/networking/ssh.nix
boot.kernel.sysctl."net.ipv4.ip_forward" = 1;
networking.nftables.ruleset = mkAfter ''
table inet filter {
+ chain forward-to-lan {
+ #jump forward-connectivity
+ counter accept
+ }
chain forward-to-net {
#jump forward-connectivity
counter accept
"${wifiIPv4}.1:53"
];
+ services.openssh.settings.X11Forwarding = true;
+
+ services.vnstat.enable = true;
+
+ systemd.services.sshd.serviceConfig.LoadCredentialEncrypted = [
+ "host.key:${ssh/host.key.cred}"
+ ];
}