boot.loader.grub = {
enable = true;
version = 2;
- device = "/dev/disk/by-id/ata-Samsung_SSD_850_PRO_128GB_S1SMNSAFC36436X";
- configurationLimit = 3;
+ devices = [
+ "/dev/disk/by-id/ata-Samsung_SSD_850_PRO_128GB_S1SMNSAFC36436X"
+ ];
+ configurationLimit = 16;
#zfsSupport = true;
#efiSupport = true;
#enableCryptodisk = true;
};
+services.udev.extraRules = ''
+ ACTION=="add", SUBSYSTEM=="tty", KERNEL=="ttyUSB*", ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9204", RUN+="${pkgs.gobi_loader}/lib/udev/gobi_loader -2000 $env{DEVNAME} /home/julm/documents/thinkpad-x201/gobi"
+'';
+
+
fileSystems."/boot" =
{ device = "/dev/disk/by-partlabel/${hostName}_ssd_boot";
fsType = "ext2";
#config.boot.kernelPackages.exfat-nofuse
];
+powerManagement.powertop.enable = true;
+#services.fprintd.enable = true;
+
fileSystems."/" =
{ device = "${hostName}/root";
fsType = "zfs";