../nixos/profiles/builder.nix
../nixos/profiles/debug.nix
../nixos/profiles/graphical.nix
+ ../nixos/profiles/irssi.nix
../nixos/profiles/lang-fr.nix
../nixos/profiles/printing.nix
+ ../nixos/profiles/radio.nix
../nixos/profiles/tor.nix
- ../nixos/profiles/irssi.nix
oignon/backup.nix
oignon/hardware.nix
oignon/networking.nix
"dialout"
"lp"
"networkmanager"
+ "plugdev" # For rtl-sdr
"scanner"
"tor"
"video"
secret-key-files = /run/credentials/nix-daemon.service/${hostName}.key
'';
settings = {
- trusted-users = [ config.users.users."julm".name ];
substituters = [
#"http://nix-localcache.losurdo.wg"
"ssh://nix-ssh@losurdo.wg?priority=30"
services.davfs2.enable = true;
+ systemd.automounts = [
+ { where = "/mnt/aubergine"; automountConfig.TimeoutIdleSec = "5 min"; }
+ ];
fileSystems =
- # Use the user's gpg-agent session to query
- # for the password of the SSH key when auto-mounting.
let
- sshAsUser = user:
- pkgs.writeScript "sshAsUser-${user}" ''
- exec ${pkgs.sudo}/bin/sudo -i -u ${user} \
+ # Use the user's gpg-agent session to query
+ # for the password of the SSH key when auto-mounting.
+ sshAsUser =
+ pkgs.writeScript "sshAsUser" ''
+ user="$1"; shift
+ exec ${pkgs.sudo}/bin/sudo -i -u "$user" \
${pkgs.openssh}/bin/ssh "$@"
'';
options =
[
- "noatime"
- "noexec"
- "nosuid"
"user"
"uid=julm"
"gid=users"
"allow_other"
+ "exec" # Override "user"'s noexec
+ "noatime"
+ "nosuid"
"_netdev"
- "ssh_command=${sshAsUser "julm"}" # "reconnect"
+ "ssh_command=${sshAsUser}\\040julm"
"noauto"
"x-gvfs-hide"
"x-systemd.automount"
# Disconnect approximately 2*15=30 seconds after a network failure
"ServerAliveCountMax=1"
"ServerAliveInterval=15"
+ "dir_cache=no"
+ #"reconnect"
];
in
{