debug: install dfeet
[julm/julm-nix.git] / hosts / oignon / backup.nix
index 13c8db5567be4c3b94093ebf858f47f3e8a57417..3425e52432d3c1e62a08aa9d2d114c08f5a15b73 100644 (file)
@@ -1,6 +1,8 @@
 { pkgs, lib, config, hostName, ... }:
 with builtins;
 {
+# syncoid --create-bookmark --no-privilege-elevation --no-sync-snap --recvoptions '' --sendoptions raw --recursive oignon/home off2/julm/backup/oignon/home
+# zfs list -t snapshot -o name | grep ^oignon/home | while read -r snap; do zfs bookmark "$snap" "${snap//@/#}"; done
 # Take regular snapshots, and prune old ones
 services.sanoid = {
   enable = true;
@@ -15,10 +17,6 @@ services.sanoid = {
       yearly = 0;
       recursive = true;
     };
-    "${hostName}/home/room" = {
-      autosnap = false;
-      autoprune = false;
-    };
     "${hostName}/var" = {
       autosnap = true;
       autoprune = true;
@@ -28,6 +26,15 @@ services.sanoid = {
       yearly = 0;
       recursive = true;
     };
+    "off2/julm/backup/oignon" = {
+      autosnap = false;
+      autoprune = true;
+      hourly = 0;
+      daily = 7;
+      monthly = 3;
+      yearly = 0;
+      recursive = true;
+    };
   };
 };
 # Trigger backups when disks are plugged
@@ -183,7 +190,7 @@ programs.bash.interactiveShellInit = ''
     trap "sudo zpool export $zpool" EXIT
     zfs list -rH -t filesystem -o mounted,mountpoint,name "$zpool"/"$USER"/backup |
     grep "^no\\s*/" | cut -f 3 | xargs -ortL1 sudo zfs mount -Olv || true
-    ${pkgs.mate.caja}/bin/caja --browser /mnt/"$zpool"/"$USER"/backup
+    ${pkgs.mate.caja-with-extensions}/bin/caja --browser /mnt/"$zpool"/"$USER"/backup
     )
   }
 '';