julm: oignon: install transmission-remote-gtk
[julm/julm-nix.git] / nixos / profiles / system.nix
index b987a3460e2f4484a8847e8d2c072df19eaec097..9b16ed1a616e5060a10f9a2c584509fbd0915218 100644 (file)
@@ -28,7 +28,7 @@ with lib;
       ../../home-manager/options.nix
       ../../home-manager/profiles/essential.nix
     ];
-    services.gpg-agent.pinentryFlavor = "curses";
+    services.gpg-agent.pinentryPackage = pkgs.pinentry-curses;
   };
   nix = {
     settings.auto-optimise-store = mkDefault true;
@@ -36,7 +36,18 @@ with lib;
     gc.dates = mkDefault "weekly";
     gc.options = mkDefault "--delete-older-than 7d";
     nixPath = mkForce [ ];
+    # Pin the rev to the revision of the public Nixpkgs that the system was built from.
+    # This is the version which will be locked by flakes using flake:nixpkgs
     #registry.nixpkgs = mkDefault { flake = inputs.nixpkgs; };
+    registry.nixpkgs = {
+      from = { id = "nixpkgs"; type = "indirect"; };
+      to = {
+        owner = "NixOS";
+        repo = "nixpkgs";
+        inherit (inputs.nixpkgs) rev;
+        type = "github";
+      };
+    };
     package = pkgs.nixFlakes;
     settings.experimental-features = [ "nix-command" "flakes" "repl-flake" ];
   };
@@ -58,7 +69,7 @@ with lib;
     enable = mkDefault true;
     enableRootSlice = mkDefault true;
     enableSystemSlice = mkDefault true;
-    enableUserServices = mkDefault true;
+    enableUserSlices = mkDefault true;
   };
   systemd.services.openssh = {
     serviceConfig = {