xsettingsd: enable service for dynamic GTK theme switching
[julm/julm-nix.git] / home-manager / profiles / starship.nix
index 21fc830c785cd44e22a9c0387b0eb59fc1f5b613..5492416b4c58a70fe4c32124fc93562c94f76741 100644 (file)
       custom = { };
     };
   };
+  programs.bash = {
+    initExtra = ''
+      function set_win_title(){
+        echo -ne "\033]0;Term: $USER@$HOSTNAME: $PWD\007"
+      }
+      starship_precmd_user_func="set_win_title"
+    '';
+  };
 }