fcitx5: tweak classicui settings
[julm/julm-nix.git] / flake.nix
index ded6fc06149de97328c32e153e83b65d90670d7b..8a1dc6b7414c07f0514d9b72121186204a987a74 100644 (file)
--- a/flake.nix
+++ b/flake.nix
@@ -1,4 +1,5 @@
 {
+  description = "julm's Nix configurations for hosts (NixOS) and homes (home-manager)";
   /*
     nixConfig = {
     extra-substituters = [
   inputs = {
     doom-emacs.flake = false;
     doom-emacs.url = "github:hlissner/doom-emacs";
-    home-manager.inputs.nixpkgs.follows = "nixpkgs";
-    home-manager.url = "github:nix-community/home-manager/release-24.11";
-    nix-formatter-pack.inputs.nixpkgs.follows = "nixpkgs";
-    nix-formatter-pack.url = "github:Gerschtli/nix-formatter-pack";
-    nixpkgs.url = "github:NixOS/nixpkgs/nixos-24.11";
     git-hooks.inputs.nixpkgs.follows = "nixpkgs";
-    git-hooks.inputs.nixpkgs-stable.follows = "nixpkgs";
     git-hooks.url = "github:cachix/git-hooks.nix";
+    home-manager.inputs.nixpkgs.follows = "nixpkgs";
+    home-manager.url = "github:nix-community/home-manager/release-24.11";
     nixos-hardware.url = "github:NixOS/nixos-hardware/master";
+    nixpkgs.url = "github:NixOS/nixpkgs/nixos-24.11";
   };
 
   outputs =
@@ -80,6 +78,7 @@
                 "el"
                 "hs"
                 "json"
+                "lua"
                 "nix"
                 "patch"
                 "pem"
           };
         }
       );
-
-      # nix fmt
-      formatter = forAllSystems (
-        { pkgs, ... }:
-        inputs.nix-formatter-pack.lib.mkFormatter {
-          inherit pkgs;
-          config = {
-            tools = {
-              deadnix.enable = true;
-              nixfmt-rfc-style.enable = true;
-              statix.enable = true;
-            };
-          };
-        }
-      );
     };
 }