bash: alias lst
[julm/julm-nix.git] / hosts / aubergine / hardware.nix
index 23af21c9ad1fd2c06d251c9e691b16f217d5c153..0f6d90f97c93146344aa95f1316dae81a7e9acf5 100644 (file)
@@ -3,6 +3,7 @@
   imports = [
     ../../nixos/profiles/hardware/apu6b4.nix
     ../../nixos/profiles/hardware/ME909u-521.nix
+    ../../nixos/profiles/serial.nix
     ../../nixos/profiles/zfs.nix
     ../../nixos/profiles/zramSwap.nix
   ];
     #efiSupport = true;
     #enableCryptodisk = true;
   };
-  boot.tmp.useTmpfs = true;
-  #boot.kernelPackages = pkgs.linuxKernel.packages.linux_4_14;
-  # linux-firmware-20230515
-  # linux-firmware-20221109
-  # linux-5.15.109 <-- working?
-  # linux-5.15.129
 
   boot.supportedFilesystems = [ /*"ntfs"*/ "vfat" ];
   boot.extraModulePackages = [
     #config.boot.kernelPackages.exfat-nofuse
   ];
+  boot.zfs.requestEncryptionCredentials = [ hostName ];
+
+  hardware.enableRedistributableFirmware = true;
 
   powerManagement.powertop.enable = true;
+
   #services.fprintd.enable = true;
 
   fileSystems."/" =