{ pkgs, lib, config, ... }:
{
-import = [
+imports = [
./aria2c.nix
];
-home.packages = [ pkgs.yt-dlp ];
+home.packages = [
+ # error: phantomjs 1.9.8 has been dropped due to lack of maintenance and security issues
+ #pkgs.phantomjs
+ pkgs.yt-dlp
+];
xdg.configFile."yt-dlp/config".text = ''
- --download-archive .downloaded
+ #--download-archive .downloaded
+ --embed-chapters
+ --embed-subs
+ --sub-langs all
--format ${lib.concatStringsSep "/" [
- "bestvideo[height=360][ext=mp4]+bestaudio"
- "bestvideo[height<=480][ext=mp4]+bestaudio"
- "best[height=360][ext=mp4]"
- "best[height<=480][ext=mp4]"
- "best[height=360]"
- "best[height<=480]"
+ #"bestvideo[height=360][ext=mp4]+bestaudio"
+ "bestvideo[height=480][ext=mp4]+bestaudio"
+ #"best[height=360][ext=mp4]"
+ "best[height=480][ext=mp4]"
+ #"best[height=360]"
+ "best[height=480]"
"best"
]}
- --output %(upload_date>%Y-%m-%d)s - %(title)s.%(id)s.%(format_id)s.%(ext)s
+ --output "%(upload_date>%Y-%m-%d)s - %(title)s.%(id)s.%(format_id)s.%(ext)s"
--prefer-free-formats
+ --sub-format ass/srt/best
+ --user-agent Mozilla/5.0
'';
}