home-manager: update
[julm/julm-nix.git] / home-manager / profiles / bash.nix
index 9d14205d6785af4a700051e2cb417c6e05717459..71cd7ccd4a7ecec07d0303e199d8e293470f9b74 100644 (file)
@@ -9,11 +9,15 @@ with lib;
       black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
       c = "bat";
       cl = "clear";
+      d = "sudo resolvectl";
       dust = "dust --bars-on-right --full-paths";
       emacs = "emacsclient --create-frame";
       grep = "grep --color";
       j = "sudo journalctl -u";
       jb = "sudo journalctl -b";
+      jf = "sudo journalctl -f -u";
+      jf200 = "sudo journalctl -f -n 200 -u";
+      jftoday = "sudo journalctl -f --since today -u";
       ju = "journalctl --user -u";
       l = "ls -alh";
       ll = "ls -al";
@@ -48,6 +52,7 @@ with lib;
       theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
       theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
       u = "systemctl --user";
+      ud = "resolvectl";
       ur = "systemctl --user restart";
       ut = "systemctl --user status";
       w = "watch --color --differences";
@@ -68,7 +73,10 @@ with lib;
       zs5 = "w5 zpool status";
       zu = "zfs-unmount";
     };
-    historyControl = [ "erasedups" "ignorespace" ];
+    historyControl = [
+      "erasedups"
+      "ignorespace"
+    ];
     historyIgnore = [
       "torify"
       "mpv"
@@ -231,8 +239,7 @@ with lib;
         done
       }
     '';
-    profileExtra = ''
-    '';
+    profileExtra = '''';
   };
   #programs.broot.enableBashIntegration = true;
   programs.readline = {