-{ pkgs, lib, config, inputs, ... }:
+{ pkgs, config, ... }:
{
systemd.sockets."tmux@" = {
listenStreams = [ "/home/%i/tmux.sock" ];
socketConfig.Service = "tmux@%i.service";
};
/*
- systemd.services."proxy-to-irssi@" = {
+ systemd.services."proxy-to-irssi@" = {
requires = ["irssi@%i.service"];
after = ["irssi@%i.service" "proxy-to-irssi-%i.socket"];
#unitConfig.JoinsNamespaceOf = ["netns-${netns}.service"];
#PrivateNetwork = true;
PrivateTmp = true;
};
- };
+ };
*/
#systemd.sockets."irssi@" = {
# enable = values.peersAnnouncing.enable;
serviceConfig = {
Type = "notify";
#GuessMainPID = true;
- ExecStart = "${pkgs.tmux} -v -D -f /var/lib/tmux/%i/.config/tmux/tmux.conf -f ${pkgs.writeText "tmux.conf" ''
+ ExecStart = "${pkgs.tmux}/bin/tmux -v -D -f /var/lib/tmux/%i/.config/tmux/tmux.conf -f ${pkgs.writeText "tmux.conf" ''
set-option -g default-shell ${pkgs.runtimeShell}
#set-option -g exit-empty off
new-session -d
NotifyAccess = "all";
#RuntimeDirectory = ["tmux/%i"];
#RuntimeDirectoryMode = "755";
- StateDirectory = ["tmux/%i"];
+ StateDirectory = [ "tmux/%i" ];
#TimeoutSec = 5;
ExecStop = [
# Send CTRL+u to clear the input line before /quit