avahi: disable useless nssmdns6
[julm/julm-nix.git] / nixos / profiles / irssi.nix
index 51bacf1de831b0b0653400a49c26bb6f4a441052..b767c3342ebc0e7869afc88cceacd7e689016293 100644 (file)
@@ -1,4 +1,4 @@
-{ pkgs, lib, config, inputs, ... }:
+{ pkgs, config, ... }:
 {
   systemd.sockets."tmux@" = {
     listenStreams = [ "/home/%i/tmux.sock" ];
@@ -7,7 +7,7 @@
     socketConfig.Service = "tmux@%i.service";
   };
   /*
-  systemd.services."proxy-to-irssi@" = {
+    systemd.services."proxy-to-irssi@" = {
     requires = ["irssi@%i.service"];
     after = ["irssi@%i.service" "proxy-to-irssi-%i.socket"];
     #unitConfig.JoinsNamespaceOf = ["netns-${netns}.service"];
@@ -17,7 +17,7 @@
       #PrivateNetwork = true;
       PrivateTmp = true;
     };
-  };
+    };
   */
   #systemd.sockets."irssi@" = {
   #  enable = values.peersAnnouncing.enable;
@@ -39,7 +39,7 @@
     serviceConfig = {
       Type = "notify";
       #GuessMainPID = true;
-      ExecStart = "${pkgs.tmux} -v -D -f /var/lib/tmux/%i/.config/tmux/tmux.conf -f ${pkgs.writeText "tmux.conf" ''
+      ExecStart = "${pkgs.tmux}/bin/tmux -v -D -f /var/lib/tmux/%i/.config/tmux/tmux.conf -f ${pkgs.writeText "tmux.conf" ''
         set-option -g default-shell ${pkgs.runtimeShell}
         #set-option -g exit-empty off
         new-session -d
@@ -48,7 +48,7 @@
       NotifyAccess = "all";
       #RuntimeDirectory = ["tmux/%i"];
       #RuntimeDirectoryMode = "755";
-      StateDirectory = ["tmux/%i"];
+      StateDirectory = [ "tmux/%i" ];
       #TimeoutSec = 5;
       ExecStop = [
         # Send CTRL+u to clear the input line before /quit