nixos-fallback: fix switch
[julm/julm-nix.git] / home-manager / profiles / yt-dlp.nix
index 56fbb901d9efcd9a9890d411b4a97b1656c3876d..b5f473620fe7197c22e7a99635cbbc162b540e60 100644 (file)
@@ -10,9 +10,9 @@ home.packages = [
 ];
 xdg.configFile."yt-dlp/config".text = ''
   #--download-archive .downloaded
-  --all-subs
   --embed-chapters
   --embed-subs
+  --sub-langs all
   --format ${lib.concatStringsSep "/" [
     #"bestvideo[height=360][ext=mp4]+bestaudio"
     "bestvideo[height=480][ext=mp4]+bestaudio"
@@ -22,9 +22,11 @@ xdg.configFile."yt-dlp/config".text = ''
     "best[height=480]"
     "best"
   ]}
-  --output "%(upload_date>%Y-%m-%d)s - %(title)s.%(id)s.%(format_id)s.%(ext)s"
+  --output "%(release_date>%Y-%m-%d,upload_date>%Y-%m-%d)s - %(title)s.%(id)s.%(format_id)s.%(ext)s"
+  --match-filter !is_live
   --prefer-free-formats
   --sub-format ass/srt/best
+  --sub-langs "en.*,fr,-live_chat"
   --user-agent Mozilla/5.0
 '';
 }