aubergine: wifi: unhide SSID
[julm/julm-nix.git] / hosts / pumpkin / networking.nix
index 281efebcd54ad48965264fab8a740efa9bcbceaa..5481189fe019d873f3ed04c3d767e2aefcbaa9fb 100644 (file)
   networking.nftables.ruleset = lib.mkAfter ''
     table inet filter {
       chain input {
+        ip daddr 10.0.0.0/8 counter goto input-lan
+        ip daddr 172.16.0.0/12 counter goto input-lan
+        ip daddr 192.168.0.0/16 counter goto input-lan
+        ip daddr 224.0.0.0/3 counter goto input-lan
         goto input-net
       }
       chain output {
@@ -88,4 +92,9 @@
   systemd.services.sshd.serviceConfig.LoadCredentialEncrypted = [
     "host.key:${ssh/host.key.cred}"
   ];
+
+  programs.wireshark = {
+    enable = true;
+    package = pkgs.wireshark-qt;
+  };
 }