pumpkin: steam-run: install
[julm/julm-nix.git] / nixos / profiles / hardware / T14sAMDGen1.nix
index 4102ee42f1b349782d3053724cc1ab0a3ade31b3..ff0d74d16c4bcabc533aaf49136c59c1ca3450ff 100644 (file)
@@ -1,4 +1,10 @@
-{ pkgs, lib, config, inputs, ... }:
+{
+  pkgs,
+  lib,
+  config,
+  inputs,
+  ...
+}:
 with lib;
 {
   imports = [
@@ -11,6 +17,8 @@ with lib;
   nixpkgs.hostPlatform = {
     system = "x86_64-linux";
     config = "x86_64-unknown-linux-gnu";
+    #gcc.arch = "znver3";
+    #gcc.tune = "znver3";
   };
 
   boot.kernelModules = [
@@ -51,6 +59,8 @@ with lib;
   hardware.trackpoint.enable = mkDefault true;
   hardware.trackpoint.emulateWheel = mkDefault config.hardware.trackpoint.enable;
 
+  # WarningNote: be sure to "allow Windows UEFI updates"
+  # See https://github.com/fwupd/fwupd/wiki/PluginFlag:capsules-unsupported
   services.fwupd.enable = true;
   services.upower.enable = true;
   services.libinput.enable = mkDefault true;