printing: improve setup
[julm/julm-nix.git] / hosts / courge / hardware.nix
index 49fd8cc1163e5475b4f48ea6bd5e24b1cd9d9a89..9e2a833db6f0c5ae5a335ae0365143c674363c76 100644 (file)
@@ -23,7 +23,8 @@ with lib;
     "boot.shell_on_fail"
     #"boot.debug1"
   ];
-  boot.kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
+  # Deprecated in nixos-24.11
+  #boot.kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
   boot.loader = {
     efi = {
       canTouchEfiVariables = true;
@@ -50,7 +51,7 @@ with lib;
   hardware.enableRedistributableFirmware = true;
   # Disable IR camera
   services.udev.extraRules = ''
-    ACTION=="add", ATTRS{idVendor}=="5986", ATTRS{idProduct}=="1141", RUN="${pkgs.runtimeShell} -c 'echo 0 >/sys$devpath/authorized'"
+    ACTION=="add", ATTRS{idVendor}=="5986", ATTRS{idProduct}=="1141", RUN="${pkgs.runtimeShell} -c 'echo 1 >/sys$devpath/remove'"
   '';
 
   fileSystems."/boot1" =