xmonad: rofi: import more environment variables
[julm/julm-nix.git] / nixos / profiles / system.nix
index 9b16ed1a616e5060a10f9a2c584509fbd0915218..f243ae76e2310be0e8f6272f88606a0fa93b272d 100644 (file)
@@ -1,8 +1,15 @@
-{ config, pkgs, lib, inputs, ... }:
+{
+  config,
+  pkgs,
+  lib,
+  inputs,
+  ...
+}:
 with lib;
 {
   boot.tmp.cleanOnBoot = mkDefault true;
   boot.tmp.useTmpfs = mkDefault true;
+
   services.logrotate.enable = true;
   # NOTE: mostly useless on a server, and CPU intensive.
   documentation = {
@@ -14,6 +21,7 @@ with lib;
     nixos.enable = mkDefault false;
   };
   programs.vim.defaultEditor = mkDefault true;
+  programs.vim.enable = mkDefault true;
   environment.variables = {
     EDITOR = "vim";
     NIXPKGS_CONFIG = mkForce "";
@@ -40,16 +48,23 @@ with lib;
     # This is the version which will be locked by flakes using flake:nixpkgs
     #registry.nixpkgs = mkDefault { flake = inputs.nixpkgs; };
     registry.nixpkgs = {
-      from = { id = "nixpkgs"; type = "indirect"; };
+      from = {
+        id = "nixpkgs";
+        type = "indirect";
+      };
       to = {
         owner = "NixOS";
         repo = "nixpkgs";
         inherit (inputs.nixpkgs) rev;
-        type = "github";
+        # May be overriden by nixos/modules/installer/cd-dvd/channel.nix
+        type = mkDefault "github";
       };
     };
-    package = pkgs.nixFlakes;
-    settings.experimental-features = [ "nix-command" "flakes" "repl-flake" ];
+    package = pkgs.nixVersions.stable;
+    settings.experimental-features = [
+      "nix-command"
+      "flakes"
+    ];
   };
   security.lockKernelModules = false;
   services.journald = {
@@ -71,7 +86,7 @@ with lib;
     enableSystemSlice = mkDefault true;
     enableUserSlices = mkDefault true;
   };
-  systemd.services.openssh = {
+  systemd.services.sshd = {
     serviceConfig = {
       ManagedOOMPreference = "omit";
     };