-{ config, pkgs, lib, inputs, ... }:
+{
+ config,
+ pkgs,
+ lib,
+ inputs,
+ ...
+}:
with lib;
{
boot.tmp.cleanOnBoot = mkDefault true;
boot.tmp.useTmpfs = mkDefault true;
+
services.logrotate.enable = true;
# NOTE: mostly useless on a server, and CPU intensive.
documentation = {
nixos.enable = mkDefault false;
};
programs.vim.defaultEditor = mkDefault true;
+ programs.vim.enable = mkDefault true;
environment.variables = {
EDITOR = "vim";
NIXPKGS_CONFIG = mkForce "";
# This is the version which will be locked by flakes using flake:nixpkgs
#registry.nixpkgs = mkDefault { flake = inputs.nixpkgs; };
registry.nixpkgs = {
- from = { id = "nixpkgs"; type = "indirect"; };
+ from = {
+ id = "nixpkgs";
+ type = "indirect";
+ };
to = {
owner = "NixOS";
repo = "nixpkgs";
inherit (inputs.nixpkgs) rev;
- type = "github";
+ # May be overriden by nixos/modules/installer/cd-dvd/channel.nix
+ type = mkDefault "github";
};
};
- package = pkgs.nixFlakes;
- settings.experimental-features = [ "nix-command" "flakes" "repl-flake" ];
+ package = pkgs.nixVersions.stable;
+ settings.experimental-features = [
+ "nix-command"
+ "flakes"
+ ];
};
security.lockKernelModules = false;
services.journald = {
enableSystemSlice = mkDefault true;
enableUserSlices = mkDefault true;
};
- systemd.services.openssh = {
+ systemd.services.sshd = {
serviceConfig = {
ManagedOOMPreference = "omit";
};