};
# iw dev wlp5s0 station dump
# DOC: https://w1.fi/cgit/hostap/plain/hostapd/hostapd.conf
+ systemd.services.hostapd = {
+ unitConfig.StartLimitIntervalSec = 5;
+ serviceConfig.Restart = "always";
+ };
services.hostapd = {
enable = true;
logLevel = 2;
# a=5GHz, g=2.4GHz
hwMode = "g";
ssid = hostName;
- wpa = false;
+ wpa = true;
inherit wpaPassphrase;
countryCode = "FR";
extraConfig = ''
ieee80211d=1
disassoc_low_ack=1
ignore_broadcast_ssid=1
+ macaddr_acl=0
# WPA2
+ #auth_algs=0 # 0=noauth, 1=wpa, 2=wep, 3=both
wpa_key_mgmt=WPA-PSK
wpa_pairwise=CCMP
rsn_pairwise=CCMP
- auth_algs=1 # 0=noauth, 1=wpa, 2=wep, 3=both
- macaddr_acl=0
# QoS support, also required for full speed on 802.11n/ac/ax
wmm_enabled=1
eap_reauth_period=360000