pumpkin: signal: install
[julm/julm-nix.git] / home-manager / profiles / vim.nix
index 207121e50a91b16f67d58409f7e5ac918e6b9210..f57c01fb7d9ac3835b3940e8fb573fd17cd500d0 100644 (file)
@@ -1,5 +1,13 @@
-{ pkgs, lib, config, nixosConfig, ... }:
-let inherit (builtins) readFile; in
+{
+  pkgs,
+  lib,
+  config,
+  nixosConfig,
+  ...
+}:
+let
+  inherit (builtins) readFile;
+in
 {
   programs.vim = {
     enable = lib.mkDefault true;
@@ -7,8 +15,7 @@ let inherit (builtins) readFile; in
       readFile vim/init.vim
       #+ readFile home/vim/syntastic.vim
       #+ readFile home/vim/coc.vim
-      + readFile vim/ale.vim
-    ;
+      + readFile vim/ale.vim;
     # Plugin list:
     # nix-instantiate -E --eval 'builtins.attrNames (import <nixpkgs> {}).vimPlugins'
     plugins = [
@@ -39,19 +46,21 @@ let inherit (builtins) readFile; in
       #pkgs.vimPlugins.fugitive
       pkgs.vimPlugins.vim-ghcid-quickfix
     ];
-  } /* // lib.optionalAttrs (!nixosConfig.services.xserver.enable) {
-    packageConfigurable =
-      # This has the drawback of recompiling/sending vim
-      pkgs.vim-full.override {
-        features = "normal";
-        config.vim.gui = "none";
-      };
-  }*/;
+  }
+  /*
+    // lib.optionalAttrs (!nixosConfig.services.xserver.enable) {
+      packageConfigurable =
+        # This has the drawback of recompiling/sending vim
+        pkgs.vim-full.override {
+          features = "normal";
+          config.vim.gui = "none";
+        };
+    }
+  */
+  ;
 
   programs.neovim = {
-    extraConfig =
-      readFile vim/init.vim +
-      readFile vim/ale.vim;
+    extraConfig = readFile vim/init.vim + readFile vim/ale.vim;
     plugins = [
       #pkgs.vimPlugins.vim-lsc
       pkgs.vimPlugins.gitgutter