-{ pkgs, lib, config, nixosConfig, ... }:
-let inherit (builtins) readFile; in
+{
+ pkgs,
+ lib,
+ config,
+ nixosConfig,
+ ...
+}:
+let
+ inherit (builtins) readFile;
+in
{
programs.vim = {
enable = lib.mkDefault true;
readFile vim/init.vim
#+ readFile home/vim/syntastic.vim
#+ readFile home/vim/coc.vim
- + readFile vim/ale.vim
- ;
+ + readFile vim/ale.vim;
# Plugin list:
# nix-instantiate -E --eval 'builtins.attrNames (import <nixpkgs> {}).vimPlugins'
plugins = [
#pkgs.vimPlugins.fugitive
pkgs.vimPlugins.vim-ghcid-quickfix
];
- } /* // lib.optionalAttrs (!nixosConfig.services.xserver.enable) {
- packageConfigurable =
- # This has the drawback of recompiling/sending vim
- pkgs.vim-full.override {
- features = "normal";
- config.vim.gui = "none";
- };
- }*/;
+ }
+ /*
+ // lib.optionalAttrs (!nixosConfig.services.xserver.enable) {
+ packageConfigurable =
+ # This has the drawback of recompiling/sending vim
+ pkgs.vim-full.override {
+ features = "normal";
+ config.vim.gui = "none";
+ };
+ }
+ */
+ ;
programs.neovim = {
- extraConfig =
- readFile vim/init.vim +
- readFile vim/ale.vim;
+ extraConfig = readFile vim/init.vim + readFile vim/ale.vim;
plugins = [
#pkgs.vimPlugins.vim-lsc
pkgs.vimPlugins.gitgutter