julm/mutt.nix
(import (julm/hosts + "/${hostName}.nix"))
];
+ programs.bash.shellAliases = {
+ firefox-calyx = "sudo systemd-run -P -p JoinsNamespaceOf=netns-calyx.service -p PrivateNetwork=true -p BindReadOnlyPaths=/etc/netns/calyx/resolv.conf:/etc/resolv.conf -E DISPLAY=$DISPLAY -p User=julm -E DBUS_SESSION_BUS_ADDRESS=$DBUS_SESSION_BUS_ADDRESS -E LANG=$LANG -E LOCALE_ARCHIVE=$LOCALE_ARCHIVE -E PATH=$PATH -- firefox -P calyx";
+ };
programs.firefox.profiles =
let
defaultProfile = {
id = 1;
name = "tor";
settings = {
- "browser.startup.homepage" = "https://check.torproject.org/";
+ "browser.startup.homepage" = "https://check.torproject.org";
+ "privacy.firstparty.isolate" = true;
+ };
+ }
+ ];
+ "zqa1ck7d.calyx" = lib.mkMerge [
+ defaultProfile
+ {
+ id = 2;
+ name = "calyx";
+ settings = {
+ "browser.startup.homepage" = "https://icanhazip.com";
"privacy.firstparty.isolate" = true;
};
}
"F6CCA60CF05FADAE911CFBEC0BCDED22F40A19FD"
];
programs.irssi.extraConfig = lib.readFile julm/irssi/config;
- xdg.configFile."doom-config/config.el".text = lib.readFile julm/emacs/config.el;
+ xdg.configFile."doom/config.el".text = lib.readFile julm/emacs/config.el;
home.file.".irssi/passwd".text = ''
FreeNode : ${pkgs.pass}/bin/pass freenode.net/irc/julm
GeekNode : ${pkgs.pass}/bin/pass geeknode.org/irc/julm
OFTC : ${pkgs.pass}/bin/pass oftc.net/irc/julm
ToileLibre : ${pkgs.pass}/bin/pass toile-libre.org/irc/julm
'';
- programs.ssh.matchBlocks = lib.genAttrs [ "lan.losurdo.sourcephile.fr" "losurdo.wg" ]
- (_: {
- compression = true; # Helps to get a better framerate with forwardX11
- forwardX11 = true;
- forwardX11Trusted = true;
- serverAliveInterval = 15;
- }) // {
- "patate.wg" = {
- user = "sevy";
- #proxyJump = "mermet.wg";
- };
- };
+ programs.ssh.matchBlocks =
+ {
+ "aubergine.wg" = {
+ compression = true; # Helps to get a better framerate with forwardX11
+ forwardAgent = true;
+ forwardX11 = true;
+ forwardX11Trusted = true;
+ serverAliveInterval = 15;
+ };
+ "patate.wg" = {
+ user = "sevy";
+ #proxyJump = "mermet.wg";
+ };
+ } //
+ lib.genAttrs [ "lan.losurdo.sourcephile.fr" "losurdo.wg" ]
+ (_: {
+ compression = true; # Helps to get a better framerate with forwardX11
+ forwardX11 = true;
+ forwardX11Trusted = true;
+ serverAliveInterval = 15;
+ });
programs.git = {
userName = "Julien Moutinho";
userEmail = "julm@sourcephile.fr";
- signing.key = "0x7182433A39582282929B2A222E3618DD0D087650";
+ signing.key = "0x4FE467034C11017B429BAC53A58CD81C3863926F";
signing.signByDefault = false;
extraConfig = {
sendemail.smtpEncryption = "ssl"; # Yes, "ssl", not "tls" which does not work because it expects STARTTLS.