black-on-white = "echo -e '\\033]11;black\\007\\033]10;white\\007'";
c = "bat";
cl = "clear";
+ d = "sudo resolvectl";
+ dust = "dust --bars-on-right --full-paths";
emacs = "emacsclient --create-frame";
grep = "grep --color";
j = "sudo journalctl -u";
jb = "sudo journalctl -b";
- ju = "sudo journalctl --user -u";
+ jf = "sudo journalctl -f -u";
+ jf200 = "sudo journalctl -f -n 200 -u";
+ jftoday = "sudo journalctl -f --since today -u";
+ ju = "journalctl --user -u";
l = "ls -alh";
ll = "ls -al";
ls = "ls --color=tty";
+ lst = "ls --sort=time --reverse -1";
md-toc = "grep '^#\\+' --color";
mem = "ps -e -orss=,user=,args= | sort -b -k1,1n";
mem-top = "smem --sort rss --autosize";
rsync = "rsync --no-inc-recursive --info=progress2 --inplace --partial";
s = "sudo systemctl";
sr = "sudo systemctl restart";
+ ssh-unknown = "ssh -o StrictHostKeyChecking=no -o UserKnownHostsFile=/dev/null";
st = "sudo systemctl status";
+ smt-on = "echo on | sudo tee /sys/devices/system/cpu/smt/control";
+ smt-off = "echo off | sudo tee /sys/devices/system/cpu/smt/control";
t = "tmux";
t0 = "tmux new -t 0";
t1 = "tmux new -t 1";
theme-black-on-white = "echo -e '\\033]10;black\\007\\033]11;white\\007'";
theme-white-on-black = "echo -e '\\033]10;white\\007\\033]11;black\\007'";
u = "systemctl --user";
+ ud = "resolvectl";
ur = "systemctl --user restart";
ut = "systemctl --user status";
w = "watch --color --differences";
set -x
for d in "$@"; do
for s in $(zfs list -Hrpt snapshot -o name "$d"); do
- zfs bookmark "$s" "''${s//@/#}"
+ sudo zfs bookmark "$s" "''${s//@/#}"
done
done
}
for d in $(zfs list -rHo name "$1" | tail -n +2); do
echo >&2 "$d"
test "$(zfs get -Ho value encryptionroot $d)" = "$1" ||
- zfs change-key -li "$d"
+ sudo zfs change-key -li "$d"
done
}
local d
for d in "$@"; do
zfs list -t snapshot -rHo name "$d" |
- xargs --no-run-if-empty -L1 zfs destroy
+ sudo xargs --no-run-if-empty -L1 zfs destroy
done
}
'';