pumpkin: syncoid: exclude games
[julm/julm-nix.git] / home-manager / profiles / graphical.nix
index 0ee0f8e2b77de4f137c01b61c66401c89a8d82ce..046118b562a522fc3665441ea324e4b5156b4de4 100644 (file)
@@ -1,4 +1,10 @@
-{ pkgs, lib, config, nixosConfig, ... }:
+{
+  pkgs,
+  lib,
+  config,
+  nixosConfig,
+  ...
+}:
 {
   imports = [
     ./redshift.nix
     keycode 59 = semicolon period comma less ellipsis multiply ccedilla Ccedilla
     !   (nbsp) with AltGr+space and   (narrow nbsp) with AltGr+Shift+space
     keycode 65 = space space NoSymbol NoSymbol nobreakspace U202F
+
+    ! Use Caps Lock button for compose key
+    keysym Caps_Lock = Multi_key Caps_Lock
+    ! Remove shift lock functionality
+    clear Lock
   '';
   systemd.user.services.setxkbmap.Service.ExecStartPost =
     "${pkgs.xorg.xmodmap}/bin/xmodmap ${config.home.homeDirectory}/.Xmodmap";