-{ pkgs, lib, config, ... }:
+{ pkgs, ... }:
{
-home.packages = [
- pkgs.mpv
-];
-xdg.configFile."mpv/input.conf".text = ''
- # Volume normalization
- # See https://github.com/mpv-player/mpv/issues/3979
- Alt+a cycle-values af "dynaudnorm=f=75:g=25:n=0:p=0.58" "loudnorm" ""
- Alt+f cycle video-unscaled
-'';
-xdg.configFile."mpv/mpv.conf".text = ''
- # Do not require DISPLAY for audio files
- audio-display=no
- hwdec=auto-safe
- profile=gpu-hq
- # Terminal is disabled by --player-operation-mode=pseudo-gui in mpv.desktop
- terminal=yes
- vo=gpu
- ytdl-format=18/mp4-480p/hls-480p/http-360p/mp4
-'';
-# Prioritize mpv over mplayer
-xdg.mimeApps.defaultApplications = {
- "audio/mpeg" = ["mpv.desktop"];
- "audio/ogg" = ["mpv.desktop"];
- "audio/opus" = ["mpv.desktop"];
- "video/mp4" = ["mpv.desktop"];
- "video/x-matroska" = [ "mpv.desktop" ];
-};
+ home.packages = [
+ pkgs.mpv
+ ];
+ xdg.configFile."mpv/input.conf".text = ''
+ # Volume normalization
+ # See https://github.com/mpv-player/mpv/issues/3979
+ Alt+a cycle-values af "dynaudnorm=f=75:g=25:n=0:p=0.58" "loudnorm" ""
+ Alt+f cycle video-unscaled
+ '';
+ xdg.configFile."mpv/mpv.conf".text = ''
+ hwdec=auto-safe
+ profile=gpu-hq
+ vo=gpu
+ ytdl-format=18/mp4-480p/hls-480p/http-360p/mp4
+ '';
}