-{ config, pkgs, lib, inputs, ... }:
+{
+ config,
+ pkgs,
+ lib,
+ inputs,
+ ...
+}:
with lib;
{
boot.tmp.cleanOnBoot = mkDefault true;
# This is the version which will be locked by flakes using flake:nixpkgs
#registry.nixpkgs = mkDefault { flake = inputs.nixpkgs; };
registry.nixpkgs = {
- from = { id = "nixpkgs"; type = "indirect"; };
+ from = {
+ id = "nixpkgs";
+ type = "indirect";
+ };
to = {
owner = "NixOS";
repo = "nixpkgs";
};
};
package = pkgs.nixVersions.stable;
- settings.experimental-features = [ "nix-command" "flakes" ];
+ settings.experimental-features = [
+ "nix-command"
+ "flakes"
+ ];
};
security.lockKernelModules = false;
services.journald = {