sourcephile.fr: nebula: open HTTP output
[julm/julm-nix.git] / nixos / profiles / system.nix
index e4b7424c6f4108cb02aca2671983d9212835cad3..f243ae76e2310be0e8f6272f88606a0fa93b272d 100644 (file)
@@ -1,4 +1,10 @@
-{ config, pkgs, lib, inputs, ... }:
+{
+  config,
+  pkgs,
+  lib,
+  inputs,
+  ...
+}:
 with lib;
 {
   boot.tmp.cleanOnBoot = mkDefault true;
@@ -42,7 +48,10 @@ with lib;
     # This is the version which will be locked by flakes using flake:nixpkgs
     #registry.nixpkgs = mkDefault { flake = inputs.nixpkgs; };
     registry.nixpkgs = {
-      from = { id = "nixpkgs"; type = "indirect"; };
+      from = {
+        id = "nixpkgs";
+        type = "indirect";
+      };
       to = {
         owner = "NixOS";
         repo = "nixpkgs";
@@ -52,7 +61,10 @@ with lib;
       };
     };
     package = pkgs.nixVersions.stable;
-    settings.experimental-features = [ "nix-command" "flakes" ];
+    settings.experimental-features = [
+      "nix-command"
+      "flakes"
+    ];
   };
   security.lockKernelModules = false;
   services.journald = {