inputs = {
doom-emacs.flake = false;
doom-emacs.url = "github:hlissner/doom-emacs";
- home-manager.inputs.nixpkgs.follows = "nixpkgs";
- home-manager.url = "github:nix-community/home-manager/release-24.11";
- nix-formatter-pack.inputs.nixpkgs.follows = "nixpkgs";
- nix-formatter-pack.url = "github:Gerschtli/nix-formatter-pack";
- nixpkgs.url = "github:NixOS/nixpkgs/nixos-24.11";
git-hooks.inputs.nixpkgs.follows = "nixpkgs";
- git-hooks.inputs.nixpkgs-stable.follows = "nixpkgs";
git-hooks.url = "github:cachix/git-hooks.nix";
+ home-manager.inputs.nixpkgs.follows = "nixpkgs";
+ home-manager.url = "github:nix-community/home-manager/release-24.11";
nixos-hardware.url = "github:NixOS/nixos-hardware/master";
+ nixpkgs.url = "github:NixOS/nixpkgs/nixos-24.11";
+ lanzaboote = {
+ url = "github:nix-community/lanzaboote/v0.4.2";
+ inputs.nixpkgs.follows = "nixpkgs";
+ };
};
outputs =
"el"
"hs"
"json"
+ "lua"
"nix"
"patch"
"pem"
modules = [
nixos/default.nix
(import (self + "/hosts/${hostName}.nix"))
+ inputs.lanzaboote.nixosModules.lanzaboote
(
{ config, ... }:
{
};
}
);
-
- # nix fmt
- formatter = forAllSystems (
- { pkgs, ... }:
- inputs.nix-formatter-pack.lib.mkFormatter {
- inherit pkgs;
- config = {
- tools = {
- deadnix.enable = true;
- nixfmt-rfc-style.enable = true;
- statix.enable = true;
- };
- };
- }
- );
};
}