NO_AT_BRIDGE = "1";
};
services.redshift.enable = lib.mkDefault true;
+ # keycode <num> = <x> <Shift+x> _ _ <AltGr+x> <AltGr+Shift+x> _ _"
home.file.".Xmodmap".text = ''
- ! œ and Œ with AltGr+o and AltGr+Shift+o
- keycode 32 = o O o O oe OE
+ ! — (tiret insécable) with AltGr+Shift+-
+ keycode 15 = minus 6 bar fiveeighths bar U2011
+ ! — (tiret cadratin) with AltGr+Shift+_
+ keycode 17 = underscore 8 bar fiveeighths backslash emdash
+ ! œ with AltGr+o
+ ! Œ with AltGr+Shift+o
+ keycode 32 = o O o O oe OE
+ ! … (ellipsis) with AltGr+;
+ keycode 59 = semicolon period comma less ellipsis multiply ccedilla Ccedilla
+ ! (nbsp) with AltGr+space and (narrow nbsp) with AltGr+Shift+space
+ keycode 65 = space space NoSymbol NoSymbol nobreakspace U202F
'';
systemd.user.services.setxkbmap.Service.ExecStartPost =
"${pkgs.xorg.xmodmap}/bin/xmodmap ${config.home.homeDirectory}/.Xmodmap";
+ programs.bash.shellAliases = {
+ gtk-light = "dconf write /org/gnome/desktop/interface/color-scheme '\"prefer-light\"'";
+ gtk-dark = "dconf write /org/gnome/desktop/interface/color-scheme '\"prefer-dark\"'";
+ };
+ dconf.settings = {
+ "org/gnome/desktop/interface" = {
+ color-scheme = "prefer-dark";
+ };
+ };
+ gtk = {
+ theme.name = "Adwaita";
+ gtk2.configLocation = "${config.xdg.configHome}/gtk-2.0/gtkrc";
+ gtk3 = {
+ bookmarks = lib.mkDefault [
+ ];
+ };
+ };
}