"boot.shell_on_fail"
#"boot.debug1"
];
- boot.kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
+ # Deprecated in nixos-24.11
+ #boot.kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
boot.loader = {
efi = {
canTouchEfiVariables = true;
boot.zfs.requestEncryptionCredentials = [ "${hostName}/root" ];
hardware.enableRedistributableFirmware = true;
+ # Disable IR camera
+ services.udev.extraRules = ''
+ ACTION=="add", ATTRS{idVendor}=="5986", ATTRS{idProduct}=="1141", RUN="${pkgs.runtimeShell} -c 'echo 1 >/sys$devpath/remove'"
+ '';
fileSystems."/boot1" =
{