inxi: add to essentials
[julm/julm-nix.git] / hosts / courge / hardware.nix
index dff5f5fae39bcac83b31b773626fe601d453a2bc..9e2a833db6f0c5ae5a335ae0365143c674363c76 100644 (file)
@@ -23,7 +23,8 @@ with lib;
     "boot.shell_on_fail"
     #"boot.debug1"
   ];
-  boot.kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
+  # Deprecated in nixos-24.11
+  #boot.kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
   boot.loader = {
     efi = {
       canTouchEfiVariables = true;
@@ -48,6 +49,10 @@ with lib;
   boot.zfs.requestEncryptionCredentials = [ "${hostName}/root" ];
 
   hardware.enableRedistributableFirmware = true;
+  # Disable IR camera
+  services.udev.extraRules = ''
+    ACTION=="add", ATTRS{idVendor}=="5986", ATTRS{idProduct}=="1141", RUN="${pkgs.runtimeShell} -c 'echo 1 >/sys$devpath/remove'"
+  '';
 
   fileSystems."/boot1" =
     {