xsettingsd: enable service for dynamic GTK theme switching
[julm/julm-nix.git] / home-manager / profiles / git.nix
index 3fbb4e1d52499ba3bef619a526d84dea23de1caf..677f4a68a6340329c5dcea9c104c96f9fbb00884 100644 (file)
@@ -53,7 +53,8 @@
       p = "push -v";
       pa = "patch";
       patch = "push rad HEAD:refs/patches";
-      pf = "push -vf";
+      # See https://stackoverflow.com/a/65839129/6741004
+      pf = "push -v --force-with-lease --force-if-includes";
       pl = "pull";
       r = "reset";
       rh = "reset --hard";
@@ -64,6 +65,7 @@
       spush = "!git-svn dcommit";
       ss = "status -s";
       st = "status -uno";
+      stu = "status -unormal";
       sw = "switch";
       fetch-local = "!git fetch local && git tag -d $(git describe --exact-match 2>/dev/null >/dev/null) && git fetch --tags local";
       pull-local = "!git fetch-local && git checkout -B master local/master";
       protocol.version = 2;
       pull.rebase = true;
       push.default = "simple";
+      push.useForceIfIncludes = true;
       rebase.autosquash = "true";
       sendemail.chainReplyTo = "false";
       sendemail.composeencoding = "UTF-8";