-{ pkgs, lib, config, inputs, hostName, ... }:
+{
+ pkgs,
+ lib,
+ config,
+ inputs,
+ hostName,
+ ...
+}:
let
domain = "sourcephile.fr";
iface = config.services.nebula.networks.${domain}.tun.device;
in
{
imports = [
- ../../share/nebula/sourcephile.fr.nix
+ ../../domains/sourcephile.fr/nebula.nix
];
services.nebula.networks.${domain} = {
listen.port = 10007;
firewall = {
inbound = [
- { port = "any"; proto = "any"; groups = [ "sourcephile" "intra" ]; }
+ {
+ port = "any";
+ proto = "any";
+ groups = [
+ "sourcephile"
+ "intra"
+ ];
+ }
];
outbound = [
- { port = "any"; proto = "any"; host = "any"; }
+ {
+ port = "any";
+ proto = "any";
+ host = "any";
+ }
];
};
settings = {