pumpkin: adb: enable
[julm/julm-nix.git] / hosts / courge / nebula.nix
index 0c3123b01b7a2041e9f92493a50293e5cb92b154..8207828e004d5cd7739c2dbf64ae40ecec8fa178 100644 (file)
@@ -1,20 +1,38 @@
-{ pkgs, lib, config, inputs, hostName, ... }:
+{
+  pkgs,
+  lib,
+  config,
+  inputs,
+  hostName,
+  ...
+}:
 let
   domain = "sourcephile.fr";
   iface = config.services.nebula.networks.${domain}.tun.device;
 in
 {
   imports = [
-    ../../share/nebula/sourcephile.fr.nix
+    ../../domains/sourcephile.fr/nebula.nix
   ];
   services.nebula.networks.${domain} = {
     listen.port = 10007;
     firewall = {
       inbound = [
-        { port = "any"; proto = "any"; groups = [ "sourcephile" "intra" ]; }
+        {
+          port = "any";
+          proto = "any";
+          groups = [
+            "sourcephile"
+            "intra"
+          ];
+        }
       ];
       outbound = [
-        { port = "any"; proto = "any"; host = "any"; }
+        {
+          port = "any";
+          proto = "any";
+          host = "any";
+        }
       ];
     };
     settings = {