-{ config, pkgs, lib, inputs, hostName, ... }:
+{
+ config,
+ pkgs,
+ lib,
+ inputs,
+ hostName,
+ ...
+}:
{
imports = [
../nixos/profiles/debug.nix
../nixos/profiles/radio.nix
../nixos/profiles/tor.nix
../nixos/profiles/bluetooth.nix
+ ../nixos/profiles/home.nix
pumpkin/backup.nix
pumpkin/syncoid.nix
pumpkin/hardware.nix
services.davfs2.enable = true;
systemd.automounts = [
- { where = "/mnt/aubergine"; automountConfig.TimeoutIdleSec = "5 min"; }
+ {
+ where = "/mnt/aubergine";
+ automountConfig.TimeoutIdleSec = "5 min";
+ }
];
fileSystems =
let
# Use the user's gpg-agent session to query
# for the password of the SSH key when auto-mounting.
- sshAsUser =
- pkgs.writeScript "sshAsUser" ''
- user="$1"; shift
- exec ${pkgs.sudo}/bin/sudo -i -u "$user" \
- ${pkgs.openssh}/bin/ssh "$@"
- '';
- options =
- [
- "user"
- "uid=julm"
- "gid=users"
- "allow_other"
- "exec" # Override "user"'s noexec
- "noatime"
- "nosuid"
- "_netdev"
- "ssh_command=${sshAsUser}\\040julm"
- "noauto"
- "x-gvfs-hide"
- "x-systemd.automount"
- #"Compression=yes" # YMMV
- # Disconnect approximately 2*15=30 seconds after a network failure
- "ServerAliveCountMax=1"
- "ServerAliveInterval=15"
- "dir_cache=no"
- #"reconnect"
- ];
+ sshAsUser = pkgs.writeScript "sshAsUser" ''
+ user="$1"; shift
+ exec ${pkgs.sudo}/bin/sudo -i -u "$user" \
+ ${pkgs.openssh}/bin/ssh "$@"
+ '';
+ options = [
+ "user"
+ "uid=julm"
+ "gid=users"
+ "allow_other"
+ "exec" # Override "user"'s noexec
+ "noatime"
+ "nosuid"
+ "_netdev"
+ "ssh_command=${sshAsUser}\\040julm"
+ "noauto"
+ "x-gvfs-hide"
+ "x-systemd.automount"
+ #"Compression=yes" # YMMV
+ # Disconnect approximately 2*15=30 seconds after a network failure
+ "ServerAliveCountMax=1"
+ "ServerAliveInterval=15"
+ "dir_cache=no"
+ #"reconnect"
+ ];
in
{
"/mnt/aubergine" = {
fsType = "fuse";
inherit options;
};
- "/mnt/ilico/severine" = {
- device = "https://nuage.ilico.org/remote.php/dav/files/severine/";
- fsType = "davfs";
- options =
- let
- conf = pkgs.writeText "davfs2.conf" ''
- backup_dir /home/julm/.local/share/davfs2/ilico/severine
- secrets /home/julm/.davfs2/secrets
- '';
- in
- [
- "conf=${conf}"
- "user"
- "noexec"
- "nosuid"
- "noauto"
- "nofail"
- "_netdev"
- "reconnect"
- "x-systemd.automount"
- "x-systemd.device-timeout=1m"
- "x-systemd.idle-timeout=1m"
- "x-systemd.mount-timeout=10s"
- ];
- };
+ /*
+ "/mnt/ilico/severine" = {
+ device = "https://nuage.ilico.org/remote.php/dav/files/severine/";
+ fsType = "davfs";
+ options =
+ let
+ conf = pkgs.writeText "davfs2.conf" ''
+ backup_dir /home/julm/.local/share/davfs2/ilico/severine
+ secrets /home/julm/.davfs2/secrets
+ '';
+ in
+ [
+ "conf=${conf}"
+ "user"
+ "noexec"
+ "nosuid"
+ "noauto"
+ "nofail"
+ "_netdev"
+ "reconnect"
+ "x-systemd.automount"
+ "x-systemd.device-timeout=1m"
+ "x-systemd.idle-timeout=1m"
+ "x-systemd.mount-timeout=10s"
+ ];
+ };
+ */
};
services.kubo = {