wine: add profile
[julm/julm-nix.git] / nixos / profiles / zfs.nix
index dff137f2fe193b6c9274f669e62b9af80e007747..55cf0ca9255da991a0dd231150677fcac64a4b19 100644 (file)
@@ -1,4 +1,9 @@
-{ pkgs, lib, hostName, ... }:
+{
+  pkgs,
+  lib,
+  hostName,
+  ...
+}:
 {
   # none is the recommended elevator with ZFS (which has its own I/O scheduler)
   services.udev.extraRules = ''
       PrivateTmp = true;
       SyslogIdentifier = "zfs-import@%i";
       Restart = "no";
-      ExecStart = pkgs.writeShellScript "zfs-import" ''
-        pool="$1"
-        set -eux
-        zpool status "$pool" ||
-        zpool import -lFd /dev/disk/by-id/ -o cachefile=none "$pool" ||
-        zpool reopen "$pool" ||
-        zpool import -lfd /dev/disk/by-id/ -o cachefile=none "$pool" ||
-        zpool clear -nFX "$pool"
-        ${pkgs.systemd}/bin/systemctl restart zfs-mount.service
-      '' + " %I";
+      ExecStart =
+        pkgs.writeShellScript "zfs-import" ''
+          pool="$1"
+          set -eux
+          zpool status "$pool" ||
+          zpool import -lFd /dev/disk/by-id/ -o cachefile=none "$pool" ||
+          zpool reopen "$pool" ||
+          zpool import -lfd /dev/disk/by-id/ -o cachefile=none "$pool" ||
+          zpool clear -nFX "$pool"
+          ${pkgs.systemd}/bin/systemctl restart zfs-mount.service
+        ''
+        + " %I";
     };
   };
 }