../../nixos/profiles/zramSwap.nix
];
+ boot.kernelParams = [
+ # Avoids huge slow downs, especially with nix.
+ "zfs.zfs_arc_max=${toString (1024 * 1024 * 1024)}" # bytes
+ ];
+
# Setting the machine-id avoids to reencrypt all credentials
# when reinstalling NixOS on a new drive.
# Manually generated with : uuidgen | tr -d -
enable = true;
memtest86.enable = true;
mirroredBoots = [
- { path = "/boot1"; devices = [ "/dev/disk/by-id/ata-CT250MX500SSD1_2004E2849DD5" ]; }
+ {
+ path = "/boot1";
+ devices = [ "/dev/disk/by-id/ata-CT250MX500SSD1_2004E2849DD5" ];
+ }
];
# Roughly 25MiB (initrd) + 9MiB (kernel) per configuration
configurationLimit = 6;
hardware.enableRedistributableFirmware = true;
- fileSystems."/boot1" =
- {
- device = "/dev/disk/by-partlabel/${hostName}_ssd1_boot";
- fsType = "vfat";
- options = [ "rw" "noexec" "nodev" "nofail" "X-mount.mkdir" "iocharset=iso8859-1" ];
- };
+ fileSystems."/boot1" = {
+ device = "/dev/disk/by-partlabel/${hostName}_ssd1_boot";
+ fsType = "vfat";
+ options = [
+ "rw"
+ "noexec"
+ "nodev"
+ "nofail"
+ "X-mount.mkdir"
+ "iocharset=iso8859-1"
+ ];
+ };
swapDevices = [
{
device = "/dev/disk/by-partlabel/${hostName}_ssd1_swap";
}
];
- boot.supportedFilesystems = [ "ntfs" "vfat" ];
+ boot.supportedFilesystems = [
+ "ntfs"
+ "vfat"
+ ];
- fileSystems."/" =
- {
- device = "${hostName}/root";
- fsType = "zfs";
- options = [ "zfsutil" ];
- };
- fileSystems."/nix" =
- {
- device = "${hostName}/root/nix";
- fsType = "zfs";
- options = [ "X-mount.mkdir" "zfsutil" ];
- };
- fileSystems."/var" =
- {
- device = "${hostName}/root/var";
- fsType = "zfs";
- options = [ "X-mount.mkdir" "zfsutil" ];
- };
+ fileSystems."/" = {
+ device = "${hostName}/root";
+ fsType = "zfs";
+ options = [ "zfsutil" ];
+ };
+ fileSystems."/nix" = {
+ device = "${hostName}/root/nix";
+ fsType = "zfs";
+ options = [
+ "X-mount.mkdir"
+ "zfsutil"
+ ];
+ };
+ fileSystems."/var" = {
+ device = "${hostName}/root/var";
+ fsType = "zfs";
+ options = [
+ "X-mount.mkdir"
+ "zfsutil"
+ ];
+ };
services.pipewire.jack.enable = true;
-
}