xsettingsd: enable service for dynamic GTK theme switching
[julm/julm-nix.git] / hosts / blackberry / nebula.nix
index 9bd97172fae2e752bceab93a42c1514a95d27375..9b8bb1e7c5cdd138a8dfc8de8ac3c66087c4f7a5 100644 (file)
@@ -1,11 +1,12 @@
-{ pkgs, lib, config, inputs, hostName, ... }:
+{ pkgs, lib, config, inputs, hostName, hosts, ... }:
 let
   domain = "sourcephile.fr";
   iface = config.services.nebula.networks.${domain}.tun.device;
+  aubergine = import ../aubergine/networking/names-and-numbers.nix;
 in
 {
   imports = [
-    ../../share/nebula/sourcephile.fr.nix
+    ../../domains/sourcephile.fr/nebula.nix
   ];
   services.nebula.networks.${domain} = {
     listen.port = 10008;
@@ -17,6 +18,10 @@ in
         { port = "any"; proto = "any"; host = "any"; }
       ];
     };
+    staticHostMap = {
+      # Speed up discovering of aubergine at startup
+      "10.0.0.6" = [ "${aubergine.eth2IPv4}.1:${toString hosts.aubergine.config.services.nebula.networks.${domain}.listen.port}" ];
+    };
     settings = {
       punchy = {
         punch = true;