inxi: add to essentials
[julm/julm-nix.git] / hosts / blackberry / hardware.nix
index 2abef939c6a36c208a88f8ab3515aa4b64a4e723..1af798729c4bf771b7f7dfc87975b5a2a861b9a4 100644 (file)
@@ -6,6 +6,11 @@
     ../../nixos/profiles/zramSwap.nix
   ];
 
+  boot.kernelParams = [
+    # Avoids huge slow downs, especially with nix.
+    "zfs.zfs_arc_max=${toString (1024 * 1024 * 1024)}" # bytes
+  ];
+
   # Setting the machine-id avoids to reencrypt all credentials
   # when reinstalling NixOS on a new drive.
   # Manually generated with : uuidgen | tr -d -
@@ -74,5 +79,4 @@
     };
 
   services.pipewire.jack.enable = true;
-
 }