-{ lib, ... }:
+{ pkgs, lib, ... }:
with lib;
with (import networking/names-and-numbers.nix);
{
networking/lte.nix
networking/nftables.nix
../../nixos/profiles/dnscrypt-proxy2.nix
+ ../../nixos/profiles/printing.nix
../../nixos/profiles/networking/ssh.nix
];
install.substituteOnDestination = false;
services.avahi = {
enable = true;
openFirewall = true;
- nssmdns4 = true;
publish = {
enable = true;
addresses = true;
userServices = true;
workstation = true;
};
+ reflector = true;
};
# WARNING: settings.listen_addresses are not merged...
# hence there all defined here.
systemd.services.sshd.serviceConfig.LoadCredentialEncrypted = [
"host.key:${ssh/host.key.cred}"
];
+
+ programs.wireshark = {
+ enable = true;
+ package = pkgs.wireshark-cli;
+ };
}