direnv: add to essential
[julm/julm-nix.git] / hosts / aubergine / hardware.nix
index bcc4fa618b39787e9c09b84442e5268bd9e3af08..62da31c3c9405fb04d4088b27bcc9a7205becf7b 100644 (file)
@@ -6,6 +6,7 @@
     ../../nixos/profiles/serial.nix
     ../../nixos/profiles/zfs.nix
     ../../nixos/profiles/zramSwap.nix
+    ../../nixos/profiles/pipewire.nix
   ];
 
   # Setting the machine-id avoids to reencrypt all credentials
@@ -42,6 +43,7 @@
   boot.extraModulePackages = [
     #config.boot.kernelPackages.exfat-nofuse
   ];
+  boot.zfs.requestEncryptionCredentials = [ hostName ];
 
   hardware.enableRedistributableFirmware = true;
 
@@ -91,7 +93,4 @@
       }
     ];
 
-  hardware.pulseaudio.enable = lib.mkDefault true;
-  #hardware.pulseaudio.tcp.enable = lib.mkDefault true;
-
 }