avahi: disable useless nssmdns6
[julm/julm-nix.git] / home-manager / profiles / mpv.nix
index 30b44459aa93d401073a6676e0761a4612b3d3b5..906569bbdfb180b18757bdc96bfb1e8e352e6109 100644 (file)
@@ -2,10 +2,12 @@
 {
   programs.mpv = {
     enable = true;
+    # TipNote: Use mpv --input-test --force-window --idle to get the key names.
     bindings = {
       # Volume normalization
       # See https://github.com/mpv-player/mpv/issues/3979
-      "Alt+a" = ''cycle-values af "loudnorm=I=-25:TP=-1.5:LRA=1:linear=false" "dynaudnorm=framelen=100:gausssize=10:coupling=1:peak=0.58" "speechnorm" ""'';
+      "Alt+a" =
+        ''cycle-values af "loudnorm=I=-25:TP=-1.5:LRA=1:linear=false" "dynaudnorm=framelen=100:gausssize=10:coupling=1:peak=0.58" "speechnorm" ""'';
       "Alt+f" = "cycle video-unscaled";
 
       # Show all chapters (like a right-clic on |<< or >>|)
       "ESC" = "quit-watch-later";
       "Q" = "quit";
       "ENTER" = "playlist-next force";
+      "KP_ENTER" = "playlist-next force";
 
       "Alt+BS" = "playlist-remove current";
     };
     config = {
+      af = "loudnorm=I=-25:TP=-1.5:LRA=1:linear=false";
+
       hwdec = "auto-safe";
       profile = "gpu-hq";
       vo = "gpu";
 
       # Higher quality screenshots. Low compression rate to speed up saving.
       screenshot-directory = "~/Images/mpv";
+      screenshot-template = "%{filename:unknown}.%wH-%wM-%wS-%wT";
       screenshot-format = "avif";
       screenshot-avif-encoder = "libsvtav1";
       screenshot-avif-pixfmt = "yuv420p";
-      # TODO: change crf = " wrt. resolution";
+      # TODO: change crf wrt. resolution
       screenshot-avif-opts = "crf=24,aq-mode=complexity";
       screenshot-high-bit-depth = "yes";
       screenshot-tag-colorspace = "yes";
+
+      osd-font-size = 24;
     };
     profiles = {
       "extension.gif" = {
@@ -57,4 +65,5 @@
       };
     };
   };
+  xdg.configFile."mpv/scripts/history.lua".source = mpv/scripts/history.lua;
 }