inxi: add to essentials
[julm/julm-nix.git] / hosts / oignon.nix
index 131f61cb98e37d886d022ead1493a5a4339b817c..85321c00aec049e62ddd85bad4573449a2604bd1 100644 (file)
@@ -1,21 +1,23 @@
 { config, pkgs, lib, inputs, hostName, ... }:
 {
   imports = [
-    ../nixos/profiles/builder.nix
     ../nixos/profiles/debug.nix
     ../nixos/profiles/graphical.nix
     ../nixos/profiles/irssi.nix
     ../nixos/profiles/lang-fr.nix
+    ../nixos/profiles/laptop.nix
     ../nixos/profiles/printing.nix
     ../nixos/profiles/radio.nix
     ../nixos/profiles/tor.nix
+    ../nixos/profiles/bluetooth.nix
     oignon/backup.nix
     oignon/hardware.nix
+    oignon/nebula.nix
     oignon/networking.nix
   ];
 
   # Lower kernel's security for better performances
-  boot.kernelParams = [ "mitigations=off" ];
+  security.kernel.mitigations = "off";
 
   home-manager.users.julm = {
     imports = [ ../homes/julm.nix ];
     ];
   };
 
-  systemd.services.nix-daemon.serviceConfig.LoadCredentialEncrypted =
-    [ ("${hostName}.key:${inputs.self}/hosts/${hostName}/nix/secret-key-files.priv.pem.cred") ];
+  systemd.services.nix-daemon.serviceConfig.LoadCredentialEncrypted = [
+    "${hostName}.key:${builtins.path { path = ./. + "/${hostName}/nix/secret-key-files.priv.pem.cred"; }}"
+  ];
   nix = {
     extraOptions = ''
       secret-key-files = /run/credentials/nix-daemon.service/${hostName}.key
     '';
     settings = {
       substituters = [
-        #"http://nix-localcache.losurdo.wg"
-        "ssh://nix-ssh@losurdo.wg?priority=30"
+        #"http://nix-localcache.losurdo.sp"
+        "ssh://nix-ssh@losurdo.sp?priority=30"
       ];
       trusted-public-keys = map lib.readFile [
         ../users/nix/ssh/losurdo.pub
     in
     {
       "/mnt/aubergine" = {
-        device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@aubergine.wg:/";
+        device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@aubergine.sp:/";
         fsType = "fuse";
         inherit options;
       };
       "/mnt/losurdo" = {
-        device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@losurdo.wg:/";
+        device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@losurdo.sp:/";
         fsType = "fuse";
         inherit options;
       };
       "/mnt/mermet" = {
-        device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@mermet.wg:/";
+        device = "${pkgs.sshfs-fuse}/bin/sshfs#julm@mermet.sp:/";
         fsType = "fuse";
         inherit options;
       };
   ];
 
   services.xserver = {
-    layout = "fr,us(altgr-intl)";
+    xkb = {
+      layout = "fr,us(altgr-intl)";
+    };
     desktopManager = {
       session = [
         # Let the session be generated by home-manager
         }
       ];
     };
-    displayManager = {
-      defaultSession = "home-manager";
-      #defaultSession = "none+xmonad";
-      #defaultSession = "mate";
-      #defaultSession = "cinnamon";
-      autoLogin = {
-        user = config.users.users.julm.name;
-      };
+  };
+
+  services.displayManager = {
+    defaultSession = "home-manager";
+    #defaultSession = "none+xmonad";
+    #defaultSession = "mate";
+    #defaultSession = "cinnamon";
+    autoLogin = {
+      user = config.users.users.julm.name;
     };
   };