emacs: fix doom config
[julm/julm-nix.git] / shell.nix
index 722a0000b42dccee618a16d8512974daa9c8c5c4..048264a8d56ffd8d32b4a419cbd05ae4a40f7171 100644 (file)
--- a/shell.nix
+++ b/shell.nix
@@ -1,11 +1,15 @@
-{ pkgs, inputs, system, nixpkgsPath, ... }:
+{ pkgs, inputs, system, nixpkgsPath, shellHook ? "", ... }:
 pkgs.mkShell {
   name = "shell";
   src = null;
   #preferLocalBuild = true;
   #allowSubstitutes = false;
   buildInputs = [
-    (pkgs.nixos []).nixos-install
+    (pkgs.nixos [ ]).nixos-install
+    pkgs.gnumake
+    pkgs.gptfdisk
+    pkgs.gnupg
+    pkgs.pinentry-curses
   ];
   #enableParallelBuilding = true;
   NIX_PATH = pkgs.lib.concatStringsSep ":" [
@@ -18,5 +22,6 @@ pkgs.mkShell {
     PATH="${inputs.home-manager.defaultPackage.${system}}/bin:$PATH"
     PASSWORD_STORE_DIR=$PWD
     nix-store --add-root nixpkgs.root --indirect --realise ${nixpkgsPath}
+    ${shellHook}
   '';
 }